No network connection after installation

dang - it’s almost the same wireless card that I’m trying to get online (BMC4350) - I ended up plugging a USB Ethernet into the machine for now. :-/

1 Like

I could try out an external USB WiFi (ASUS USB-N13 802.11b/g/n).
Any suggestions how to achieve this?

If you have a sys-usb, you should just be able to plug it into the machine, see it pop up as a USB-device in the top bar, and assign it to the sys-net qube and available networks should pop u
p in the top bar. :crossed_fingers:

I already tried out a directly connected (wired) ethernet cable (ethernet to thunderbold and ethernet to usb as well) without any success.

No sys-usb present. Any information (reference, link etc.) how to create it?

Maybe this:


– I don’t know the difference between 11,1 and 11,2 … :-/

First of all thank you!!! I will report the result.

sys-usb created.
External USB WiFi recognized.
Now, trackpad & mouse are dead!

…and this solution helped!

1 Like

External usb works fine, and I can establish WiFi connections to the Internet.
Any way, the suggested solution here ([Networking basics on qubes - #3 by unman]) doesn’t work. Maybe some details are still missing…(!?)
Another side effect using sys-usb is that the touchpad does not work, even after applying the solution indicated here ([Mouse and tablet can't click-and-drag using sys-usb · Issue #6453 · QubesOS/qubes-issues · GitHub]), it’s not possible resize or move any window, even if the mouse can be moved, and clicking works as well.

Well, I have followed this description and installed broadcom-wl without errors.
However, when I run lsmod | grep wl , I get no output at all.
The command modprobe wl gives me this error message:
modprobe: FATAL: Module wl not found in directory /lib/modules/5.15.81-1.fc32.qubes.x86_64
What am I doing wrong?
Any suggestions?

That’s where I’m lazy and just use a usb-ethernet dongle - I think it’s something about the running kernel version (5.15.81-1)vs. the kernel version that the broadcom-wl module is build for - try:

find /lib/modules | grep wl.ko

sudo find /lib/modules | grep wl.ko => No output at all.

Discrepancies between the kernel version and the module should logically prevent installation, right?

It looks like you didn’t follow that topic, because there it’s said:

set it’s kernel to empty value (use own kernel)

and from above it is obvious that you are using Qubes provided kernel

You can try to search my topics about building RTL88xxau drivers related to Qubes provided kernels and native kernels, as well as with dkms.

What worked for me and what I can suggest you is to create minimal template, to install native kernel there, to install pvgrub2-pvh and set that for its kernel, to assure to boot in such a template, to build the driver there, to create sys-net (!) in PVH (!) mode using pvgrub2-pvh as a kernel based on a dvm based on a said template.

Now, your Broadcom should be shown under sys-usb. Do not install any Broadcom drivers in your sys-usb’s template. If so, delete the template and recreate sys-usb without Broadcom drivers. After that, just attach it from sys-usb to sys-net-PVH and check there if it works. It should, at least it works for me. And I did it using dkms. I’m preparing to create a guide about building drivers with dkms in kernel>=6.x.

I couldn’t build the drivers under Qubes provided >=6.x kernel (with dkms).

This sounds like reliable and at the same time challenging information for someone like me with only a few days of experience with Qubes. But ok, I will take up the challenge, and of course I appreciate very much any additional information, hints, guiding or support.
Thank you!

OK, this seems to be the right doc.

Taking your suggestions into account, I followed the steps shown here and created a standalone “sys-net-broadcom”. I am now getting a supposed network connection (Ethernet network VM uplink eth0), but a real network connection does not occur. Am I missing any steps yet? Any idea?

Sorry, I have no experience with standalaones with this. Only templates, as explaiend above.