No /mnt/sysimage/boot/efi/EFI/qubes/xen.cfg file exist

Trying to fix the diaplay issue and read the documentation on fixing that. It said to add a liine in /mnt/sysimage/boot/efi/EFI/qubes/xen.cfg file before rebooting amd after installation but there is no such file. What should i do?

Also there is no file on /boot/efi/EFI/qubes/xen.cfg

Hi Alex2 - and welcome to the forum! :slight_smile:

Sounds like you are reading documentation for Qubes OS 4.0 … and I assume you are installing Qubes OS 4.2 (?)

Iff you are installing Qubes OS 4.2, issues from Qubes OS 4.0 might not be needed anymore – but to be sure, can you share details like

  • What issue you have (name of hardware?)
  • Which Qubes OS version you are installing



Thanks for the replay @ChrisA
Let me tell you my issue brifly, After setup screen goes to black no more GUI. gave the verbose logs such as starting lightdm and followed with starting account service.

I rebooted the system by going in tty2 and after It stuck at decrypting disk even if I entered the passpharse correctly.I still can goto tty2. How do I solve this issue.

– Yes the version is latest 4.2
– hardware

  • nvidia 4070, intel i7 14700KF, gigabyte UD Z790

Did you select the default kernel … or did you try with kernel latest when you installed Qubes OS?

either way - have you tried the steps at:

[notice: The link is to the section about GRUB - which is used by Qubes OS 4.2]?

Does it help to replace the quiet with:

nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off



I installed with default kernel
And No, these parameters didnt work getting GUI

In the process of eliminating the simple issues/solutions:

Does your machine have 2 graphics cards -

  • An Intel card on the Motherboard
  • A Nvidia GPU as PCI

? – and if so: have you checked if the GUI is on the alternate card?

If there still is no GUI, could you try an install with kernel-latest and see if that makes a difference?


Are you sure it’s xen.cfg and not grub.cfg?

there should be this file during install:

which depending our your motherboard, you’re might need to copy that file to here as this:

if after install you can edit this:
sudo nano /etc/default/grub

or this:
sudo nano /boot/grub2/grub.cfg

I think the reference to xen.cfg is from the Community Guides → Nvidia Troubleshooting Guide … that guide is marked with “version-r40” … but it’s easy to miss that detail, when searching on Community Guides for “nvidia” and “troubleshooting” … :-/


No I only have one graphic card and that is dedicated one. The CPU which I am using is intel 14700KF which doesn’t have Integrated graphics

and as you said to install Qubes-os with kernel latest it gives errors on live boot
stuck at Cancel-mutlipath-wait-nvme0n1.service. after a moment gave Anaconda installer error

  • Missing inst.stage2 or inst.repo boot parameter on the kernel cmdline

so ?

Yes the documentation said its a xen.cfg but grub.cfg file is exist after the installation complete. so what are you referring to? and why should i edit /etc/default/grub ?

Oh - I missed the “Graphics specifications may vary depending on CPU support” (when I did a quick google for “Z790 UD”) and didn’t check the CPU … my bad :-/

My next questions:

  • Is VMD/RAID enabled or disabled in BIOS?
  • How did you write the installer?


  • VMD/RAID is disabled
  • Through Ventoy

I seem to recall an issue with Ventoy and Qubes OS 4.2, so it doesn’t work … :-/

[edit: I’ve not tried Ventoy myself, so I don’t have any first hand knowledge]


The instruction sounds like you should update this:

I’m not sure if it’s motherboard specific, but might as well update this clone file too:

Hey thanks for pointing that out. I didn’t think of secure boot option. the option was enable by default in Ventoy, I will make usb bootable using balena etcher or using ventoy but secure boot disable. see you in of minutes

So tried installing through balena etcher but no luck. Same thing as Ventoy.

dang – I’m out of ideas for how to resolve your problem … :frowning:

I hope others can help you further …:crossed_fingers:


Yeah, thanks for everything