No internet. Network icon spins but does not connect (ethernet)

Bonjour, Hello,
I’ve been trying on/off to instal and use Qubes for about a year now.
My T440p laptop is Suse/Windows, and I need it daily.
The processor and RAM are highest/top possible by manufacturer
Everytime I sort of get somewhere, I’ve spend so much time that I have to stop and go back to a runing OS to do my stuff … then months passes and when I put my mind back at it, I start all over again …
My current OS are on a separate disk. I bought a 2To disk specifically for Qubes, and is installed inside, ready.
My last attempt at installing Qubes, I decided t start from scratch, I’ve installed the most basic version, not changing ANYTHING for the default (no change in encryption, actually no encrypt at all, no pwd) and all other option are left default.
=> Qubes is up and running, and I manage to open a “Personal FF” session
=> But no Internet connection (RJ45) I see the red icon in the upper right spinning but not connecting.
If I switch WiFi on, it connects to WiFi, but my “Personal FF” still doesn’t connect.
Went back to install, and chose “USB and Network through the same thing”
Same thing happen, no internet connection through wire RJ45, but a connection (upper right red icon) through WiFi (which is not what I want)
And still no connecting with “Personal FF”
BUT … a connection with a disposable Whonix

What do you think ?

It’s hard to say what exactly is not working in your case, but it sounds like you might be missing something simple. For starters, to get the RJ45 connection working, you might have to attach your network card to your sys-net with one of the no-strict-reset or permissive options, which are described in the Qubes docs.

(Just to add, these options may have security implications.)

Thks for the quick answer. I will have a look at the doc (again) but it’s weird that something as simple as a wire connection would not work and would have security implications, while the WiFi works fine ?
Note that through the Dom_0 icon on the top right, I see my network card and RJ45 connection, Qubes just doesn’t want to connect, it start handchecking and then comes back with connection rejected or something.
Edit: I’ve re-read the doc, and don’t think it applies here, as I don’t need the VM to see my network card, as Dom_0 already sees it (just don’t want to connect …

I will have a look at the doc (again) but it’s weird that something as simple as a wire connection would not work and would have security implications, while the WiFi works fine ?

Sadly, this is related to how hardware/BIOS is often implemented currently. This is very common. How big are the security implications? I don’t know. Perhaps not that big, but I’m not an expert.

Note that through the Dom_0 icon on the top right, I see my network card and RJ45 connection, Qubes just doesn’t want to connect, it start handchecking and then comes back with connection rejected or something.

I think this could still be the reason.

Edit: I’ve re-read the doc, and don’t think it applies here, as I don’t need the VM to see my network card, as Dom_0 already sees it (just don’t want to connect …

I still think this could be the reason. The simplest way to start is to click on “Configure strict reset …” in the Devices tab in the settings for sys-net-home. Then select the wired network connection card.

I don’t need the VM to see my network card, as Dom_0 already sees it.

Dom0 always sees everything, it just doesn’t use it. You do want your net VM to be able to use your network card. I think you are confused about basic Qubes concepts. In any case, try setting “no-strict-reset” and if it doesn’t work, try “permissive” (you’ll need a command line for this). Then me or other people here can help you figure out other things.

I have no doubt I’m confused about Qubes system :smile:
My network card are:
Intel dual band AC-7260
Intel Ethernet I217-LM
I know I saw somewhere that Thinkpad T440p is compatible, but I can’t find these network card specifically

Bonjour, Hello @eric.vanh,

Network icon

First, some information about the network icon (as you say: red icon in the upper right), which is the NetworkManager Applet. This icon displays a small red cross (in the right lower bottom part of the icon) when the network doesn’t work (no connection), and no cross when the network works (workable connection).

Left click displays the available connections.

Right click displays a menu with two very useful entries:

  • Connection information : for the current connection, displays the network interface, MAC address, driver, IP, …
  • Edit connection : setting your current connection, add other connection, …

First let’s talk about your ethernet (wired) connection. Could you give us details about what you see ? Icon state, wired connection available or not, connection information, …

Testing the connection

You talked about “Personal FF” session, is it Mozilla Firefox? From which VM do you launch it? You can also test your connection with the ping command from an appVM (or from sys-net) terminal (ex: ping 8.8.8.8).

Your hardware

I searched your laptop in the Hardware for Linux database, I found it.

So I can say that your intel I217-LM ethernet card uses the very common e1000e kernel module (driver).

If you know the below commands, use them for searching more information : dmesg, ip, …

Poking and searching around, I remembered that Qubes somehow won’t connect “simply” … I’ve changed the connection to manual (DHCP doesn’t work) and put IP + DNS in hard, now i can connect to my router, but still not to the internet.
WiFi connects to the router with DHCP, but not to the internet either.
Yet, while connected with WiFi, I see a star (updater) telling me update is available for debian10, so I guess Dom_0 access to the internet somehow ?

Salut Ludovic,
Thks for your message.
Personal FF stands for personal (yellow) “service” firefox
I’ve opened a terminal in Personal, and am now pinging IPs …
From WiFi (network icon 4 bars no cross):
Ping my router, yes
Ping 8.8.8.8, yes
From Wire RJ45 (network icon 2desktops no cross):
Ping my router, yes
Ping 8.8.8.8, yes
Try again www.wikipedia.com from firefox in personal service, no luck. Settings are:
Basic. Networking sys-firewall
Adven. Provide Network
FW rules. Allow all
Èric

Qube setting

Settings for what? sys-net or Personal AppVM?

If it’s for sys-net, in Basic tab the Networking field should be none (sys-net provides itself the network connectivity).

If it’s Personal AppVM, in Advanced tab, Other section, Provides network shouldn’t be checked ! And it’s the default setting… Only VM like sys-net and sys-whonix provides network.

If above doesn’t resolve or if your setting report was a miss-report, see below.

IP setting

So it seems to be a miss-configured IP network, isn’t it? I don’t know your local network.

Check the information displayed on right click on NetworkManager applet, then connection information. Is it seem correct ?

ping 8.8.8.8 works, so maybe your got issues with your DNS availibility or DNS setting…

Do check from sys-net and from your personal VM

  • cat /etc/resolv.conf : display your DNS settings
  • host www.google.com : check the DNS resolution
  • ping www.google.com : check the DNS resolution and IP connectivity
  • ip a : display your IP setting
  • ip route : display the IP routes

On your personal VM only, from firefox, try to access to google by IP (not by hostname), ex: http://216.58.198.196 .

I hope this will help you.

Correction: my network is well set. All my 3 laptops and this tablet access it just fine, the mac address filter and FW works great.

It is something in the Quebes settings that I can’t find and is probably a simple and obvious detail. I will stop my current working session to go back to Qtubes to check your suggestion, this for that!
Èric

I know I saw somewhere that Thinkpad T440p is compatible,

There are (at least) 4 users who are running Qubes all the way from R2
to R4 on this laptop.

Intel Ethernet I217-LM

There are 23 HCLs submitted using this Ethernet card. Two of them
T440p’s. The latest entry was submitted Aug 2, 2019

… you might want to reply to this post in qubes-users asking for help.

Thank you Sven, for your confirmation.

Even if I still can’t connect, it does help for sure ! At least I’m trying something, this to you and the community

Ok, so, restarting Qubes, it came up with two new connection, ethernet network 2, and Auto ethernet. Both empty with default settings.
And when click on wifi, it didn’t create a new cnxion, probably because wifi uses default already
So Qubes doesn’t like non-default settings :wink:

I removed the “provide network” and now can access to the internet through wifi on the personal (yellow) firefox … Thank you !!
That is a very good step, but still not what I want/need, I don’t want to use wifi.

  • cat /etc/resolv.conf : settings are the same as I configured in the network manager in syst-net, and shows just the internal IP nameserver in personal
  • host www.google.com : host is unknown command
  • ping www.google.com : ping with DNS works
  • ip a : shows a lot of things, but nothing seems wrong
  • ip route : shows the same internal fake ip as with resolve.conf in personal, and in sys-net it shows the entry up of my router, the fake internal ip, and mask based on my router up

So all in all, I don’t see why Qubes refuses my wire connection with DHCP or rather, I don’t see what I set wrong in the network manager …

As I was typing my previous message on my tablet, while trying and -finally- managing to connect, I went to this page on my Qubes.
And I found the message I was typing in the draft as if I was typing it from the laptop from the beginning, it’s … hum … it feels weird

Yyeeaahh !! It connects !
Ok, so what I did is to go back to windows, and grab the settings (took a picture with my tablet) and then restart Qubes and apply it dot by dot
So apparently the gateway was the wrong one, it was the gateway of my server rather than the gateway for the laptop. Anyway, it does connect with wire now.

I guess I will never know why Qubes refuses to connect with DHCP, but I’m good with it as it is. It’s a fixed IP on my server anyway.

Ok, now, dealing with security, a secure install (my other thread) and secure connection (VPN and Tor)

Good news!

On my local network, I also use my own dhcp server, which works well with sys-net.

Try a CLI (Command Line Interface) dhcp client in verbose mode to see what your dhcp server sends to the dhcp client. (ex: dhclient -d -v <net interface>). And/or put your dhcp server in verbose mode.

Another idea, you got a wrong route (see ip route in sys-net), default route wasn’t to the ethernet gateway or interface, or too low/wrong metric…

Glad it’s solved

@eric.vanh I would like to change the title so it’s easier for others with the same problem to be able to find it. Do you think the following would be appropriate?

No internet. Network icon spins but does not connect (ethernet)

Yes, absolutely ! My orignal title is indeed not forum/user friendly!

1 Like

Could you be more specific ? What do I put instead of “Net Interface” ?

I’ve tried it, and it (obviously) give me the right information/setup while in manual (not DHCP)
But it doesn’t give me anything when I set it back to DHCP and it can’t connect …

Oh ! And my internet is suuuuuuper slow on Qubes ! (FF through Personal VM)
And many tabs won’t even open. I have 5 tabs, 1 on route IP, 1 on NAS IP, one to this page, one to Debian man, (Broken) and one to want search (broken) and one to steamOS (broken)

I’m happy to read you’ve worked around it, but it seems very strange to me that your NIC wouldn’t work with DHCP. Is it possible you have multiple DHCP servers running on your LAN, e.g. one on the server PC you mention in addition to the one on your router?
No idea why it would be so slow, though.

Could you be more specific ? What do I put instead of “Net Interface” ?

you can get a list of the net interfaces by running networkctl, it’s the link names you’re after, iirc usually ens6.