No Internet Connection or ICON

Hello Guys, i have installed my first QubesOS on my laptop. i have only whonix gateway and workstation installed. Now i need help for the configuration, i have watched many youtube videos for the internet connection but nobody helped me.
Do i need a ‘sys-net’ qube and when yes;
any manuals for this?
what template do i need?

thanks for help.

best regards,
kencho

SOLUTION: CHOOSE DEBIAN AND FEDORA ON THE INSTALLATION CONFIG

You have to manually press yes as this is the requirement to connect your Wi-Fi

Where do you think I should go ‘yes’?

Maybe he meant selecting Create default system qubes during the first boot configuration:

If you type qvm-ls | grep sys-net in a dom0 terminal, do you see any results?

You need to have either debian or fedora template to create sys-net.
Crete new qube with type AppVM, template debian/fedora, networking none.
Open Qubes Settings for this qube in Advanced tab:
Deselect “Include in Memory balancing”
Set initial memory to 400 MB
Select “Provides network”
Select Virtualization mode to HVM
In Devices tab select your network adapter.

1 Like

no, i see nothing.

okay i must reinstall now and choose fedora and debian…

You can either reinstall, making sure to select Create default system qubes and at least a template at the first boot after installation, or you can create the qubes manually without reinstalling.

And here it says how to do it: Fedora, Debian. But indeed, for new users, it’s recommended to use the default configuration during the installation.

thanks i have reinstalled now and choosen fedora and debian. now i have connection!! THANKS

1 Like