(No Internet) Caution : the default disposible template has a different net cube setting than this qube

Qubes 4.1.0 ; Ethernet cotroller ; Qualcomm Atheros killer E220x Gigabit Ethernet Controller is recognized in sys-net devices and is in selected column.

I have no internet access.
I have tried reinstalling, and redownloading ISO.
I have removed partitions and reformatted SSD each time.
network Icon in upper right task bar shows Ethernet Network (Qualcomm Athero Killer E220x Disconnected.
Basic settings for Sys-net is showing a caution Triangle for Net Qube, indicating: Caution : the default disposable template has a different net cube setting than this cub. This configuration may result in unexpected network access. Youmay wish to set the default disposable template for this cube to one with egually restrictive networking settings.
application settings for fedora-34 under selected, shows; application missing in template! (gpk-update-viewer.desktop)
other qubes are also showing ; the default disposible template has a different net cube setting than this cube.
I have spent a lot of time trying to figure this out, need help.

Thats nothing spectacular - nothing what should prevent you from accessing the internet.

But to fully explain this, here’s my explanation:

The normal way the main qubes are chained is for example

internet > sys-net > sys-firewall > personal

You accidentially or (by default) have set a disposable qube for your personal qube in qube settings → advanced > default disposable template

And this default disposable template probably have another net qube as your personal have.
In result:
personal should have sys-firewall as net qube
sys-firewall should have sys-net as net qube
and your default disposable template probably have someting else as net qube, but not “sys-firewall” as it should have if it’s the disposable template for personal.

And thats the reason for your triangle message.

1 Like

Thank you so much . I’ll be able to take another look at my Qubes install tomorrow morning around 6AM EST Canada.
I’ve spent so much time entering commands in terminal, my spouse is getting upset with me, EEE
I’m looking fwd to fallowing your suggestion tomorrow.
once again thank you.

Hopefully this provides enough detail.
I you could provide more info on the third step with the default disposable template, not sure what you meant.
a picture is provided.

You have to check the Advanced tab, what’s set under “default disposable template” for the sys-firewall qube (where the yellow triangle appears).

Is it for example “fedora-34-dvm” → then you have to go to Qubes manager > fedora-34-dvm > right click > settings > and change fedora-34-dvm’s netVM to “sys-net”

In result then: fedora-34-dvm have the same netVM, as sys-firewall have…!

…and the yellow triangle in the sys-firewall settings will disappear!

with other words:
your fedora-34-dvm have sys-firewall as netVM
your sys-firewall have sys-net as netVM

  • thats not wrong (directly), but the OS is alarming you, that you have set different netVMs and you should be aware of it! Nothing less / nothing more!

So speaking from my settings - I only take care, that my personal (based on fedora-34) AND it’s disposable (fedora-34-dvm) always have the same netVM (sys-firewall).
All other (sys-firewall / sys-net / sys-usb /etc…) have choosen “none” for Advanced > default disposable template to prevent me from these f**king yellow triangles :slight_smile:

qvm-prefs sys-net kernelopts 'pci=nomsi'

Thank you everyone for all the help, IT helps to reach out for help, This command worked for me, as mentioned by many persons Make sure you understand the command before using it.
From my understanding the kernal needs to be updated.
I don’t understand this command, it’s far to complicated for this fella, so I’ll continue using 4.0 until kernal is hopefully updated.
Best wishes to all, Stay safe.
This is the command that worked for me.
CAUTION this is not verified as secure. as mentioned I’ll be using 4.0 untill verified

s=$(qvm-prefs -- sys-net kernelopts) && qvm-prefs -- sys-net kernelopts "pci=nomsi $s"


Sorry DemiMarie posted that command line, my apologies.
Thank you DemiMarie.

s=$(qvm-prefs -- sys-net kernelopts) && qvm-prefs -- sys-net kernelopts "pci=nomsi $s"