No internet after install?

Have searched and have tried this fix below
qvm-shutdown --wait --all

qvm-pci detach sys-net dom0:00_1f.6

qvm-pci attach sys-net --persistent --option no-strict-reset=true

lspci in dom0 shows ethernet interface
qvm-pci shows persistent attached ethernet interface and no reset option = true

issue is
—> when i see the network icon, it says no devices found.
I think my ethernet adaptor is non compatible and i will need to install linux-firmware package inside sys-net
but how do i do that without accesss to internet as ofc, the command dns install linux-firmware will not work
msi z 690 pro wifi
qubes 4.1

Use lan first ? or try sys-net with fedora template.

A quick look into datasheet, nic using Intel® Wi-Fi 6E, no more info but could be ax210, ax211, ax411, if it was 210 / 211 it would automatically works in fedora.

lan is also not working, But the vif device is showing up, and i can add an ether net connection using the vif device, but i don’t know how to activate it,and do not know whether i should even be adding a connection manually.
Shouldn’t it work automatically if the ethernet cable is plugged in ??
i think i maybe facing some issue in configuring this conenction, i have lan working on windows
can u tell me how to figure out variables from windows which i can put into the fedora network configuration of the ethernet i am configuring and how to connect to that network?

variables like mac address= permanent or variable or two other options
dns = dhcp or automatic

i even tried installing linux firmware a couple of rpm’s from this page,
but i don’t know which specific one i need and i instaleld around 10 didn’t work, automatically at least

actually i tried running fedora 34 off of live usb, and the issue is that even there, it shows as wired cable unplugged.
So this is a driver issue, can you help me figuring out which driver do i need, it is working fine in endeavour os and pop os .
Is there any way i can see which particular driver for my chipset is installed in pop os

Any help is greatly appreciate

so i checked the ethernet adaptor and wifi adaptor in windows information settings
the ethernet adaptor is i225-v and the wifi is AX211.

when i said fedora, it should be fedora-35.
Try with fedora-35 live usb, will everything fine ?

if everything’s okay, there’s 2 solution for you :

  1. download using another os and transfer to qubes via flash drive.

  2. build qubes iso with fedora-35 template using master.conf

there is some issue with fedora 35 and it is not booting with my ventuoy disk, ill try booting it later, instead i have downloadewd the fedora 35 and have moved it to dom0. What is the command to install it locally???
do i just have to use sudo dnf --disablerepo=’*’ install ./abcd.rpm
or is there some specialized command in qubes? as qubes dom0 update will require internet

It’s the same command you would use for a template from the repository -

No - you use qvm-template install ./abcd.rpm

I never presume to speak for the Qubes team.
When I comment in the Forum or in the mailing lists I speak for myself.

tried installing fedora 35 net didnt work on fedora 35 even
i have a dell d3100 dock, which has an ethernet port and connects via usb 3, net doesn’t work via that too, while it does show in the vif interfaces of sys-net
here is a thread i found on reddit

according to this thread i need to upgrade to kernel 5.15 on fedora 35, is there any way i can do that?

You may want use

the iso use 5.16.15-1, but not sure because many of the test is not passed Qubes OS openQA: Test summary it’s worth to try.

i tried it, it works, was able to install and the internet is working without my having to do anything.
But there are other problems, like screen tearing and delay in graphics compositing.
Is there a way that i can install the normal release version and upgrade its kernel.
Or is there an iso of the release version with upgraded kernel

actually that the iso is the latest qubes you can build, the difference between them, stable is builded by ‘official’ qubes team, and another is ‘official dev’ by @fepitre.

what gpu you use ? do you have an “old” gpu to try ?

i tried with inbuild graphics of 12700k while the monitors are working, there is a lot of screen tearing, and delay ,other gpu i have is gt 730 gddr5, i think for that i will have to install nvidia drivers in dom 0. And i don;t know which version of nvidia drivers to install or how to install them

Just use gt 730 without installing driver would be fine too, no?

it worked here is what i had to do
yea it worked fine without driver, the compositor was causing the lag. as soon as i disabled it via alt shift f12 all was hunky dory
had to upgrade to the latest version of qubes which you linked to
1, go into the bios and change the initiazation gpu, or the gpu which is initialised first to PEG instead of IGPU. i also enabled multiple monitor support via both the igpu and dgpu from bios
2. setup arandr for multiple display settings
3. installed kde as xfce, was having an issue, getting both dgpu and igpu monitors to work
4. turn off compositor with alt shift f12 and also stop it from autostarting in the settings
this removed all the lag
however since i am on a sata ssd. the load times of vm are not that fast, but once a vm has loaded everything is instant, comparing it to a vanilla arch install with kde, only difference is vm opening time, i do not notice any other issue.

Now i have a working system with a 12700k z690 msi with ddr5. And as of now am having no issues…
I’ll mark the thread as solved as im sure someone else will come here with the same issue
thanks a lot for your support