No installer on Asrock X370 Taichi

here is my hardware:
-Asrock X370 taichi
-Ryzen 1700
-AMD RX 5700XT

So I tried getting the installer to work but i never got further than Xen (trying) to boot. No error seems to show up. I thought Qubes would work well with my system seeing this HCL:!msg/qubes-users/8s8DrjMZWBE/yciubtb_BQAJ

But I was wrong, I guess I have to wait for the 4.1 but this is frustrating. If anyone with a similar setup managed to find the magic button I would very thankful.


-AMD RX 5700XT

This is your likely answer. They do work, but require kernel-latest,
which is not in the ISO. Could you install to your disk on another
machine or borrow a GPU?

Thanks very much ! I do have another gpu, it’s an Rx 380, so you think I could get away with installing using this older card, upgrading and then swapping them ?

Well I just swapped the card and still blank so I don’t know. I will try on an old machine I got around and put the disk in my main. Maybe that will do.

You may try this:

1 Like

Hi, thanks very much for your link, it solved my problem ! I just needed to remove the lines:


The GPU caused no issue at all and Qubes works flawlessly now.

Thanks again,


1 Like

I’m happy it lead you into the right direction !

Have fun with Qubes OS :slight_smile:

1 Like