No deadkeys with Colemak keyboard layout

Edit: Since other available U.S. English layouts come with deadkeys, I assume this was a deliberate choice. I guess I will just request a version of U.S. English Colemak that comes with deadkeys.

I installed Qubes with English U.S. Colemak as the default keyboard layout. The correct layout is reflected in Settings → Keyboard.

I’ve chosen this layout on several different Linux distros and installed it to Windows, and the layout came with dead keys enabled every time. This is not the case for Qubes. Is this normal or some type of error?

The problem is that I cannot type accents nor certain non-English letters: When I press the compose key + any other key, nothing happens. I type in several European languages throughout the day, all with an English layout, so it’s not practical to switch to a different layout for each language.

Go to Qubes Menu > System Tools > Keyboard. On the Layout Tab, change “Compose key” to -

1 Like