NO Connection in any qubes but whonix

Fresh install, 4.1, I have no connection.
Only Whonix does connect using sys-whonix.
Any other qubes, with sys-firewall or sys-net does not connect.
These qubes can ping though …

I’ve tried setting up manually (IP, /24, gateway, DNS) to no avail.

What do I need to check/change in settings ?

Thank you !

PS: Writing from my Anon-Whonix qubes here.

1 Like

PS2: Downloading 4.1.2 but no hope it will magically solve this problem

I have the exact same problem !
Are you using a Thinkpad by any chance ?

Yes I do … actually, I’ve bought a P15 after reading your posts on this forum !!
in fact, … I think we have (fairly) the same config :slight_smile:

It’s unclear to me which Qubes can ping – can you ping other addresses … like




If so - can you do things like:

  • if that fails, try:
dig @

As it is a fresh install, all qubes are standards pre-confirgured.
So … disposable whonix, anon-whonix, personnal, work, etc …
All qubes using sys-whonix does Browse (firefox access the net)
All qubes using sys-firewall does not. I’ve changed to sys-net, still not.
BUT despite they can’t browse the net, they can ping the
When I change (say “personnal”) to sys-whonix, it can browse.

I don’t see the point, since it already can ping one, it sure can ping others.
DNS is same as except the 9 blocks malicious while the 8 does not :slight_smile:
Ping works (not surprised) ping works as well

user@personal: dig
<> dig 9.16.22-debian <>
global option +cmd
connectoion timed out; no servers could be reached


user@personal: dig
<> dig 9.16.22-debian <>
global option +cmd
connectoion timed out; no servers could be reached

failed as well.

Okay - so you DO have internet connection, but can’t do DNS lookup?

Note that there should be a space between and @

dig  @

– so can you redo that test?

This tells us that the problem is with DNS handling in clear net
We know that you have a working internet connection, as the Tor
connection works.

It’s possible that your connection does not provide you with a DNS
server address.
In sys-net, check the contents of /etc/resolv.conf, which should be
generated by network manager and show the IP address(es) of DNS server
provided by your ISP.
sudo nft list table nat will show you the PR-QBS chain, using dnat to
change 10.139.1.X DNS traffic to those provided DNS server IPs.
Look at those and report back.

I never presume to speak for the Qubes team. When I comment in the Forum or in the mailing lists I speak for myself.

Thks !
As soon as I manage to reinstall qubes, I will do this ! :slight_smile: