No bootable device - install Linux Mint


I am trying to install Linux Mint on a VM. I am following this article to do so which is great but after Step 5, I receive booting from Floppy. boot failed, could not read the boot disk. no bootable device.

I don’t understand what this means. I’m not using a USB stick, do I need to be using a drive or something to do this?

Thanks in advance!

Since it can’t find any “bootable device”, it’s possible the ISO is not mounted on the VM. Try to boot from CDROM and select the ISO again.

Thanks a lot, I’ll try this. The file is .iso.torrent, could this be causing a problem?

Yes, the file you downloaded is only usable by a Torrent client, it is used to download the final ISO. If you want to download the ISO directly, take the GUI you want on the download page and scroll the page a bit to see the direct links from different country/provider.

1 Like

Thanks! I now have the correct iso file. Although I’m still receiving the ‘boot failed’ error. I have tried a few more times.

Make sure you open the right VM settings and that you boot using CDROM (it’s in the advanced tab). Once you clicked that button, you should get a new window asking you to select between an already existing device or to select a file on a VM. Select the second option, select the VM where you downloaded the ISO and click on the 3 dots next to it to select the ISO. It should boot after you did that.

1 Like

Thanks for your response. I’ve been doing these exact steps however I have the iso file saved in an untrusted vm. I have made a standalone called LinuxMint and a VM called LinuxMintVM and I am doing the steps above from the LinuxMintVM and selecting the file from the untrusted VM.

Why do you have 2 VMs? One is enough for what you are trying to do. If you still can’t boot then there’s something you don’t do correctly in the steps.

Edit: Which Qubes version do you use?

1 Like

I am using Qubes 4.0. I have 1 VM (untrusted) where I originally saved the iso file and the other VM (LInuxMintVM) where I’m trying to boot using CDROM and get the iso file from untrusted.

Qubes 4.0 is going to be EOL today, you should upgrade to 4.1.

About your issue, I think I know why you can’t boot. On 4.1, Qubes mount an ESP partition, I’m not sure 4.0 support this.


Thanks a lot for letting me know, I’ll upgrade. Does this mean I won’t be able to use Linux Mint OS?

I think another reason why it may not have worked, is that it took very little time to install the .iso file whereas now I’m trying on another VM to install the .iso file and it’s taking quite a bit longer but I’m not sure.

I don’t know if Qubes 4.0 does use the boot partition, at least it works without issue on 4.1 when I tried it. You should upgrade and try the Mint installation again.

Brilliant, thanks. I’ll try that now

If you want to know how to upgrade, read that part of this blog:

1 Like