No audio output after suspend

A few weeks ago, a while after I had upgraded my laptop to Qubes 4.2.0, I started suspend on my laptop, but after resuming it there was no audio output at all from any of my qubes. However, I went to PulseAudio Volume Control and it shows that the audio playback seems to be working when I play audio in a qube – the only problem is that I cannot actually hear anything from my speakers. I tried to play some audio in a whonix disposable and a fedora qube, all unsuccessfully. Any advice on how to fix this would be greatly appreciated, thanks :smiley:

(Also, just to confirm, my volume is on and none of my qubes have their audio playback muted :smile:)

Edit: I did try muting and unmuting the playback in both the whonix disposable and the fedora qube, which didn’t work; I also tried changing the Built-in-Audio profile (under Configuration) from “Analog Stereo Duplex” to “Off” and then back to “Analog Stereo Duplex”, which also didn’t work. I haven’t done anything in the command line because I’m scared that I might accidentally break something. Hope this helps a bit!

Try to play audio from dom0:

paplay /usr/share/sounds/alsa/Front_Center.wav

But you may need to install pulseaudio-utils package in dom0 to have paplay tool:

sudo qubes-dom0-update pulseaudio-utils

You can also try to run speaker-test in dom0.

Try to comment out this line in file /etc/pulse/ (from dom0 terminal):

load-module module-suspend-on-idle

and restart pulseaudio.

I’ve just installed the package and ran that command: nothing came out of the speakers.

How do I run speaker-test in dom0?

Just run the command directly in dom0 terminal:


Check the dom0 logs using journalctl to see what’s happened to audio after resume from suspend. Maybe there will be some relevant messages.

Just run the command directly in dom0 terminal:


Forgive my ignorance, but what am I supposed to be looking for? Here’s a snippet of the output:

speaker-test 1.2.9

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2048 to 16384
Buffer size range from 1024 to 1024
Using max buffer size 16384
Periods = 4
was set period_size = 1024
was set buffer_size = 16384
 0 - Front Left
Time per period = 2.665582
 0 - Front Left
Time per period = 2.986366
 0 - Front Left
Time per period = 2.986544
 0 - Front Left
Time per period = 2.986020
 0 - Front Left
Time per period = 2.987235

You should hear the noise from speakers when this command is running.
Since you don’t seem to hear anything then the audio is not working even without pulseaudio.