No access to network share on newly installed 4.2.1

Hello all. On a recent install of 4.2.1 (on a T490) I find I am unable to add a network drive. On my previous installs (various generations of X1Cs), Ive always found Qubes worked right out-of-the box; no issues adding my network share via both files or thunar; btw no files/nautilus installed on any template with 4.2.1). Please advise. TIA.

Try to install gvfs-backends and smbclient packages in the template.

Thanks for the response, but no joy. I can access media devices via sftp, but not shared network drive. One my current laptop this isn’t a prob, and worked from the get-go w/o additional installs. FWIW, I always use Fedora templates.

It would be extremely helpful if you could say what sort of network
you are trying to connect. That’s basic information that will
help us find a solution, rather than randomly proposing you install

I never presume to speak for the Qubes team. When I comment in the Forum I speak for myself.

It’s WD My Book connected to router.

He was asking which software/protocol is used. E.g. smb / nfs / cifs / ftp / etc.


SMB works for me after installing gvfs-backends and smbclient packages and accessing share like this “smb://192.168.x.x”.

This is how i access the share with my current install; however, on new install after installing gvfs and smbclient, as soon as I input “smb” text entry box goes red as if protocol unknown/unsupported.

I only have debian templates so I’ve tried it in debian-12-xfce template. Which fedora template do you have? I’ll try it there as well.

Try to install gvfs-smb package in your fedora template.

I had already done so. Could issue be related to disposable sys-net (the only thing I’ve done different with this new install)?

It shouldn’t be related.
Are you accessing your share using IP address or domain/netbios name?
I’ve tried fedora-39-xfce template with gvfs-smb package and I could access my smb share without a problem.

Some months ago I updated fedora templates to 39 (updates ever goddamn day since). BTAIM, I never have issue with smb access. WTH changed with 4.2 release?

Are you accessing your share using IP address or domain/netbios name?
What template are you using? Is it upgraded in-place (like from fedora 38 to fedora 39) or a clean installation?

On my current laptop I access the share by IP and I did in-place Fedora update as is my habit with all previous Qubes systems. However, never had this much frequent updates 'til 39.

BTAIM, still no joy with smb share on new system.

Can you install clean fedora-39-xfce from Qubes OS repository, install gvfs-smb package and test smb?

Issue resolved. My mistake was installing gvfs alone thinking smb package was included. But, as stated earlier, on my current machine, smb worked from the get-go; also nautilus is/was default file mgr. Not so with 4.2 on new machine.