Nitropad X230 USB Installation Error

I have recently purchased a nitropad x230 with preinstalled qubes to get familiar with the setup. After successfully installing qubes 4.1.0-rc1 with various USB drives to test fresh install before i reset the HOTP/TOTP. I have reset the HOTP/TOTP code that came with the nitrokey to attempt to reset the whole laptop and start new to work my own way up and learn. I also reset the disk encryption for the HDD and wiped it. I havent tried any bios or firmware changed as i am still learning and do not want to brick anything.

FW_VER: CBET4000 Heads-v1.3.1

Kernel: Linux 4.14.62-Heads

CPU: Intel Core i7-3520M 2.9 GHz and 16GB RAM

I insert fresh install of qubes 4.1.0-rc1 on USB and select /dev/sdb1 to launch the qubes installer from GUI. As soon as head launches the installer a wild array of green/red/blue pixels symmetrically across the whole screen appears for 15 seconds. Then the screen is black for a few seconds and the 3 loading boxes with the grey background appears but more towards the top left of the screen vs the middle where it usually is. Then the installer attempts to load. Here are the error codes:

-preanaconda logging service OK

  • terminate Plymouth boot screen

The next screen shows “Not asking for VNC because we dont have a network

[drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] ERROR [CRTC:45:pipe A] flip_done timed out

[drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] [CONNECTOR:76:LVDS-1] flip_done timed out

[drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper] [PLANE:31:primary A] flip_done timed out

[drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] ERROR [CRTC:45:pipe A] flip_done timed out

If anyone has any knowledge to guide me through a successful installing it would be very helpful and appreciate.

1 Like

Welcome to the community @violetcroc11!

There is qubes-issue #6792 fixed on Aug 1st, which solves heads #789. This means you will have to use RC2 to install R4.1.

However, if you do a fresh install of R4.1 it will use cryptsetup2 which is not supported by the coreboot version that is build into your heads version. So you will need to wait until pull request #1015 was merged into heads. Then build it and flash it on your NitroPad. See also this thread with the answer from Thierry Laurion containing the above information.

It is my understanding that the only way (that doesn’t involve building and flashing a custom heads version) to install R4.1 on your NitroPad right now is to do an in-place upgrade from R4.0.


when attempting

sudo qubes-dom0-update -y qubes-dist-upgrade

I get the errors,
No match for argument qubes-dist-upgrade
nothing to download

Has this been fixed already too? thank you

RC stands for “release candidate” … this means if you want to upgrade you need to enable testing repositories.

sudo qubes-dom0-update --enablerepo=qubes-dom0-current-testing -y qubes-dist-upgrade

hi thanks for the reply again. after enabling testing repositories and running the command again I am still receiving the same error messages

Hm, maybe …

sudo qubes-dom0-update --enablerepo=qubes-dom0-unstable -y qubes-dist-upgrade

… that would make sense in a way.

thanks… but I still get the same issue. I dont mind using 4.0 but would be great to figure this upgrade out.

sudo qubes-dom0-update --enablerepo=qubes-dom0-current-testing qubes-dist-upgrade

… works for me. Make sure there are no typos.

Hello all and @Sven also have this issue but when performing

sudo qubes-dom0-update --enablerepo=qubes-dom0-current-testing qubes-dist-upgrade

I get an error “failed to specify release version please use --releasever to specify version”. to correctly specify the version of upgrade, would I enter:

sudo qubes-dom0-update --enablerepo=qubes-dom0-current-testing qubes-dist-upgrade --releasever=r4.1.0-rc2

as the whole command?