NitroPad NV41

I received the new nitropad with coreboot and heads.

My config of the Nitropad:
CPU: i5-1240P
Wifi: Intel AX200/201
OS: Qubes release 4.1.2 (R4.1)
Nitrokey: Mini USB A


Suspend and resume doesn’t work
Doesn’t work with Kernel 6.1.12-1 and 6.3.2-1.
The screen goes dark but the fans just keep running. And I can’t wake it up anymore.
I have to turn off the laptop via the power button.

The WAVLINK WL-UMD05 docking station with the revision number: Rev.c1 EU, works for me on the Thunbderbolt/USB-C port.

  • The Nitropad is connected via the docking station to a Samsung U28E590D via a display port and works with 4k resolution.
  • The USB ports, SD card slot, USB audio and network adapter (ASIX AX88179A) also work.
  • Charging also works.
  • The docking station only works when I connect it to the laptop after booting from the grub menu.
  • I can plug and unplug the docking station while in use and everything works.

I have the same docking station WAVLINK WL-UMD05 with a different revision number: Rev.e EU, which has dropouts and disconnects.

Everything else works wonderfully.


brand: |
model: |
bios: |
  Dasharo (coreboot) Heads-v2.0
cpu: |
  12th Gen Intel(R) Core(TM) i5-1240P
cpu-short: |
chipset: |
  Intel Corporation Device [8086:4621] (rev 02)
chipset-short: |
gpu: |
  Intel Corporation Device [8086:46a6] (rev 0c) (prog-if 00 [VGA controller])
gpu-short: |
network: |
  Intel Corporation Wi-Fi 6 AX210/AX211/AX411 160MHz (rev 1a)
  Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
memory: |
scsi: |

Qubes-HCL-Nitrokey-nitropad_nv41-20230618-121849.yml (856 Bytes)


Do you know if they published the code they used for Heads?

I tried looking for at on GitHub, but their Heads repo doesn’t include the NV41 board.

I have only found this on Github,

Thanks, I was just curious about the bios description, does it include the Dasharo menu?

In the config the edk2 options are disabled.

I think this is the Heads boot menu.

Yes, that looks like Heads.

The Nitrokey website also says you have to pick Dasharo or Heads, the description text just made it seem like they are using both payloads, but they are probably just using the same text for both version of the firmware.

Please report an issue on github. As I see the situation - suspend and resume is broken in R4.1 (and R4.2?) for all modern laptops and this issue is not addressed enough.
I mean laptop is like half of target audience of Qubes OS users, and suspend works in GNU/Linux distros on the same hardware. It is a big deal of a problem for many.

P.S. try with 6.2.10-1, because I saw reports that this particular version worked for some. Also run qvm-shutdown --all before trying. It will separate the issue from problems related to running qubes that are not dom0.

1 Like

Unfortunately the same problem with kernel 6.2.10-1.

In which github repository should I report this issue?

Heads is using code from Dasharo that was added to Coreboot.

Maybe the latest version of Dasharo isn’t the code used by coreboot, in v1.6.0 Dasharo fixed a issue with suspend, and the code used by coreboot could be v1.5.0 or older.

Report here: Issues · QubesOS/qubes-issues · GitHub

Thank you @kryptopunk for your HCL report, which is online now!