New/Updated templates for 4.1 (Trisquel, Debian 12, Ubuntu 2204, Kali, Mint)

I wasn’t able to announce this before.

I’ve put up new or updated templates for 4.1 -
Trisquel
Debian 12 - bookworm
Ubuntu 2204 - jammy
Kali
Linux Mint - una

Available at Index of /Templates

Feedback welcome.

6 Likes

will it be the same as we build with qubes-builder ?

bookworm and Kali - yes.
jammy - I haven’t yet put in a PR because I’m unclear on the best way of
handling reprepro. Official build will be available idc.
trisquel and mint - you will need to adapt the builder scripts.

I provide prebuilt templates for users who prefer, (for whatever reason),
not to build them.

Thanks again

Does this mean we can update it regularly via salt’s

sudo qubesctl --show-output state.sls update.qubes-dom0

later when bookworm becomes official?

You can do this right now.
(Besides the official I also host bookworm repository at https://qubes.3isec.org)

I never presume to speak for the Qubes team.
When I comment in the Forum or in the mailing lists I speak for myself.

Thanks. If I were you, would I switch already now all my debian-11 based templates to bookworm (excluding minimal based templates)?

I am unable to get audio working on Ubuntu 22.04, could you have a look at the template?

i’m rocking 4gb of ram, thanks bud.

Short question @unman : is your (new) kali template very different to mine (untouched) but up-to-date template, which always was used for getting the updates via Qubes updater ?

Belatedly.
I wouldnt switch all to bookworm - it’s a testing release that isnt
managed by the securty team.
Things will break.

Right - the builder doesn’t have the right version of headers.
But even fixing this does not get working sound.
???

Assuming that you started from bullseye and have now upgraded to
bookworm, then differences will be small.
Mine is native bookworm: yours is likely to have some cruft.

1 Like