New to qubes - Creating a new VM as NetVM

I’m new here and love this system and its potential. Im creating a new VM as a NetVM and I’m trying to assign network devices to it. I do not see my wifi within the created VM only ethernet address. How do assign all my networks to the VM to include wifi network devices or should this not include wifi and everything is already setup correctly as it is? Forgive me if I sound slow.

Aren’t your network devices already assigned to the existing sys-net qube? Have a look at the qube Settings/Devices in Qube Manager. If yes, you can also assign them to another qube, but you can’t run these two qubes simultaneously. If they aren’t anywhere, you may have a problem with the drivers/firmware. Which laptop are you using? (On recommended machines, everything works out of the box.)

Thanks for your reply. I checked and the network is using sys-net but the devices are not attached to it. When I do go to the devices tab in settings to add the network and apply it is says “can’t attach pci to VM while in pvh mode”. I’m using the Lenovo Thinkpad X1 Carbon 5th Gen i7-7600U

The VM need to be in HVM mode to attach PCI device on it. I’ve seen in your main post that you are talking about wi-fi, what’s your end goal? Take note that if you attach the same device (your wifi card in this case) on 2 different VM, you will freeze the entire system.

You can only attach a PCI device to a qube which runs in HVM mode. Change the virtualization mode of the qube in Settings/Advanced. See also: How to use PCI devices | Qubes OS and FAQ.

I can do this, and my system doesn’t freeze. Just the second qube can’t start.

Good to know, last time I did that was on 4.0 years ago and my system completely froze.

Thanks so much again. I’m following these steps here but got stuck on creating the new VM after anonymizing my mac address for my wifi and etherner.


This looks like a different question. It’s better to create a new topic for each new question, so the new users can find the answers easily.

Moved to User Support

@adw I guess this error message could be improved, so new users aren’t confused…

@adw The first page doesn’t explain the required virtualization method. I would suggest to add a link to the FAQ there.

Feel free to open an issue for this.

Added, thanks.

1 Like

I’m sorry, but I refuse to make an account with Github (Microsoft) for ethical/privacy reasons and because I disagree with their ToS. I hope someone else could create such issue.