New Qubes user on Lenovo Yoga Slim 7/IdeaPad 5 14ARE05 Ryzen: Probably need to build custom kernel. But how?

Hi and sorry for the long title.

I am a Linux user of 25 years but new on Qubes. I bought a Ryzen-based laptop and wanted to install Qubes. The only thing that doesn’t work is standby/hibernation/standby or whatever you want to call it. When ‘Modern Standby’ is enabled, it won’t wake up again. With ‘S3’ enabled instead it almost wakes up but freezes with the XScreensaver lock screen.

I read somewhere that ‘Modern Standby’ should be enabled from Linux kernel 5.14. I run 5.15 in Qubes 4.1 RC2. But since it doesn’t work, my assumption is that support for it is not built into the kernel. So now what?

I created a Qube for compiling based on Fedora 34, and did a git clone of the qubes-builder repo, found this but is stuck at the first step of “Building just the dom0 kernel” where it just seems to hang while unpacking the kernel source and not using any resources. But even if it did work, I am a bit rusty. I haven’t build a kernel in 15 years or so. And I can’t find out from the link on building how to edit the kernel config, build the kernel and install it on Dom0. So if anyone could give me any guidance on the entire process (maybe I am wrong in wanting to compile my own kernel, who knows? I really wish I didn’t have to) or just on the missing parts of the proces it would be highly appreciated.


quite high chance, in lot of system, you can’t wake it up from sleep (standby)
nonetheless, since you laptop is not in hcl, who know it will work

what command it running?

Thanks for helping out. It appears that modern standby still doesn’t work in Qubes and that S3 should. So I am trying to figure out why it doesn’t :slight_smile:

make get-sources COMPONENTS="builder-rpm linux-utils linux-kernel"