New mirrors for F38? - VPN qube corrupted with update

Specify new mirrors? VPN qube corrupted with update.

Scratch this, I figured it out (see below)
I got the same, on a clean R4.2rc4 install:
1. started fedora-38-xfce;
2. opened a console or xfce4-terminal (tried both);
3. tried several dnf commands (sudo dnf update, sudo dnf install pinta);
4. all ended in an error (no repository reachable).

I changed the “default update proxy” from sys-net to sys-firewall (after all, sys-net is the first qube vulnerable to any ME attack). Well, in R4.2rc4 this doesn’t work, leading to the error above.

Reverting the update qube to sys-net results in the desired outcome.
Global Settings → Updates → Default Update proxy

This wasn’t a problem for the past several months. A custom F38 qube could update over tor. Bypassing the firewall is far from ideal. Strange. I decided to restructure my system for everything tor. But some sites block tor, so a vpn or proxy is the best that can be done. For some reason, there is a perception that VPNs are bad and only tor is good. The solution has yet to be delivered. Maybe a simple proxy qube for when tor is blocked.

1 Like