"New lv is too large to fit in free space" for 64 GB USB stick?

I am trying to install QubesOS on a 64GB USB stick.
When I run the installer from another USB stick (as installation media) I choose the destination via the “Installation destination” screen. When I choose the automatic configuration where I reclaim all the partitions that are on it + enter encryption password I go back to the main screen with error message “Error checking storage configuration” under the “Installation destination” menu point. When clicking for details, I get this message: ‘New lv is too large to fit in free space’,‘qubes_dom0’.
From forum post in https://forum.qubes-os.org/t/test-installing-on-usb3-stick-error-checking-storage-configuration/8850 I found out that the requirements should be 32 GB - With a 64 GB showing 56 GB free I would guess this should not be an issue?
Also, as hint from the same post, I tried manual configuration, but when I try to save it I get error “Failed to find a suitable stage1 device”.
I am obviously doing something wrong here :wink: but I can’t seem to get an idea where.
The destination USB stick should be ok, low-level formatting it works nicely.
Can somebody help me with this one? Thanks!

Did you try:

  1. To wipe USB stick somewhere else and leave Qubes installer to format and partition it as needed? My advice in that case would be to reclaim not more than 90% space (~55GB) later.
  2. Another USB stick?
1 Like
  1. Yes (low-level format of the device), same results
  2. I tried another USB stick that is larger and that worked. My particular case is solved by this, thanks!
    However, still strange that an OS with requirement of 32 GB does not accept an installation on a 56 GB stick if the error message mentions a disk space problem…
1 Like

Great. Please mark the post that helped you as a solution so it could help other users too.