Network not working (Wi-Fi and Ethernet), could not attach usb devices to qubes, need help

I’m relatively new Qubes os user (using as my main OS for last 4 months), and really like the idea of separating different qubes for different purposes.
Recently I have updated dom0 and templates by running terminal commands in dom0 per qubes os documentation ( I have a thinkpad T14 gen 1 with Ryzen cpu) and shut down the laptop. Now the network is not working (no option for Wi-Fi at all) and even with Ethernet cable connection doesn’t work. In addition I could not attach any usb device (ex. yubico key, usb drive) to any qube (no devices available besides microphone). Both network and usb devices worked fine before the last update. Sys-usb, sys-net, sys-firewall are all running (at least they are green in Qube Manager). Also I could open all my qubes, but could not copy anything as network is not working and could not attach usb drive to any qube. I have updated the dom0 and other qubes using terminal before but looks like something goes wrong this time.
Please help!!!

I had a similar experience with the T490, the kernel did not support the wifi chipset. I couldn’t start the networking qubes or any qubes that depended on them, but dom0 was running without any warnings.

I read in the HCL that the fix is to change the kernel.

Don’t really know how to do it when nothing is working, maybe you can disable sys-usb and attach the controllers to dom0 or use the vault. I solved the issue by getting a laptop that supports qubes, but that is probably not the solution you are looking for.

Hmm, looks like some misconfig (from an update or somethings similar) on your system. So, can you please first check (for the network problem) sys-net > rightclick > Settings > Devices - if the both cards are visible on the right side (1x Ethernet / 1x wifi) ?

For usb devices: you first need to attach all USB devices manually to the qube you want. This can be done through the USB symbol in the taskbar/infobar > rightclick > choose USB device/entry > attach to qube (you want)…
Can you do this operation, or don’t you see any USB icon in the taskbar?

Sys-net devices display Ethernet controller and Wi-Fi 6 AX200 ( the Ethernet controller is displayed 2 times). At the same time when I right click on network icon in the taskbar (top right corner) it not display Wi-Fi option ( only enable networking and enable notifications).

Regarding the usb devices, only the microphone is available in the drop down list when I click on USB symbol (my camera that was there is missing, also I tried to use a usb flash drive, usb ssd drive and yubikey and all of them not show up in usb drop down list, so I couldn’t select any usb drive to attach to any qube except microphone.
“lsusb” command in sys-usb terminal displays a few 3.0 root hubs and 2.0 root hubs and Adomax Technology Co. Ltd QEMU USB Tablet (don’t know what is that) and no other devices (laptop camera is missing, as any connected usb devices as yubikey). Again everything was working before the update (camera, yubikey, any usb devices connected to laptop ).

It’s blocking me to use my main laptop as of now as I could not connect to my network or copy anything from any of my qubes to usb drive and try to reinstall qubes os.

In my case both Wi-Fi and usb drives attach were working fine before last update. My T14 gen 1 is not in the supported list, but most of the time it was working fine with qubes os, even it has some issues time to time but those were minor ones and a reboot fix them. Interesting, what laptop did you get and are you satisfied with it?

I’m using Qubes OS on both my X230 and X270 without any issues.

You can probably get it working if you upgrade or downgrade the kernel, I just gave up on the T490 because I needed to work and without USB and networking I wasn’t even sure how to copy a different version of the kernel to dom0.

I upgraded the Wi-Fi card in my X230 to an AX200, and that card just worked out of the box. I was considering to see if switching the Wi-Fi card would solve the issues, but didn’t have time to test it. If all else fails, you could try to remove the Wi-Fi card and see if that solves the other issues, and if it does then buy a different Wi-Fi card.

Same here, so this should be usual behaviour. If you’re left clicking the network icon, it should show the wifi or ethernet connections. Assume it’s not showing anything on your device, otherwise you wouldn’t ask.

Strange… If not popping in any other user here, I would try out if you can change things like renehoj suggested

I have disconnected the Wi-Fi card and found no changes. With Wi-Fi card physically removed, also I have removed the Wi-Fi line on the devices in sys-net and that did not fixed anything, still no network connection through Ethernet cable or usb devices available in the drop down list.

Can you run lspci in sys-net and sys-usb and show the output?

Here are 2 screenshots for sys-usb and sys-net:

I have installed a new ssd in my T14 and installed a clean qubes-os. Moved the old ssd to external enclosure and I’m able to open it using the drive encrypted password. I see a bunch of folders as 2.1 GB Volume (/dev/dm-XXX where XXX are 3 digits). When I open such folder there are: bind-dirs, config, home and usrlocal folders.
I have restored manually a few qubes/vms manually by copying my user files (usually from /dev/dmXXX/home/user/Documents).

Does anybody know if there is an easy way to restore the qubes on a new install from the old ssd? Some my qubes were restricted to specific ip addresses, browser has some url saved in toolbar and credentials saved by browser.