Network manager


I do need some help to configure network manager to be able to browse my home network. Currently I am unable to browse my home network 192.168.174.x within the Qubes installation. How do I have to add a suitable network route to the network manager in dom0 to be able to access my network resources ?

i really appreciate your kind answer very much.

Regards, hitam

dom0 doesn’t have networking enabled. sys-net has your network controller and is the one that can be connected to your local network. If you are connected with the network manager widget, you should be able to ping/connect to any local IP on your network.

Hi, i am able to ping the router from the terminal in the personal qube, however still cannot access with the file manager any network resources (SMB fileserver, etc).
Regards, Hitam

Have you installed all the dependencies for each of your services in your template?
Can you reach your services in sys-net instead of personal?

Sorry I am beginner of qubes, i do need detailed instructions to be able to follow your ideas. What kind of dependencies have to be installed ?

I still use the basic installation…

Since you are talking about SMB, you need to install gvfs-smb in your template (the one used by personal). Make sure to turn off the template and then restart your personal qube.

I opened the debian-12-xfce template, opened a terminal and tried:

sudo apt-get install gvfs-smb

E: unable to locate gvfs-smb.

after that i entered
apt-cache -search gvfs and received the following result:


gvfs-smp ist not available as separate package. is that included in another package ?
regards, hitam

Try to install gvfs-backends and smbclient for debian template.
gvfs-smb package is for fedora templates.

Ok, I did. Now there shows an icon Windows network, however which cannot be browsed. Neither by File Manager in personal nor by the Thunar File Manager.

I selected Sys-net with a right click from Qube Manager…select File Manager-- Under Networks Windows network shows—can not open / browse.

I guess broadcast is blocked by firewall by default so you can’t use network discovery.
Try to access the share directly e.g. using something like this address in File Manager smb://192.168.x.x.

i tried to access a network resource with smb://192.168.x.x the result:

No such file or directory


Did you change 12.168.x.x to the IP address of your network share?
You can try to test the connection to your share from the terminal like this:

smbclient -L x.x.x.x

Where x.x.x.x is your network share IP address.

1 Like

smbclient -L 192.168.x.x can list my network share.


Many problems that people have in Qubes are actually not Qubes specific.
This is one of those.
You can find many guides online to accessing SMB shares. Now that you
know that you have access, you could try mounting one of those shares.
Let’s say that the listing includes a share called public:
sudo mount -t cifs //192.168.x.x/public -o username=USERNAME,password=PASSWORD
should allow you to access the share at /mnt in your qube. (If there
are no access controls on the windows share, then you omit the username
and password options.)

If you are using thunar as your file manager, the share will now be
browsable at /mnt.

As you have installed gvs, you should be able to connect directly from
within thunar, although you will not be able to see the network shares
without some firewall changes.
You can though press Ctrl+L to access the location bar and enter a
URL to the network share: smb:\\192.168.x.x/public

I never presume to speak for the Qubes team.
When I comment in the Forum I speak for myself.

Please change the topic title, it does not tell much.

@unman Thank you very much for your kind reply and support.
I will try your recommendations.
reagrds, Hitam

@balko…thank you for your advice. However I do not know how to change the title of my post, because I am new in this forum. Sorry