Need help troubleshooting on laptop install

For about three or four days now I’ve been trying to install qubes on a new gaming laptop I got from a friend. For reference, the specs are here:

I keep running into this weird error no matter what I do. I’m not sure how to get the full error log to my PC but if someone can walk me through it I can pastebin it.

I’ve tried verifying the iso and everything checked out. I’ve also swapped my USB out twice and even burned the iso to a Blu-ray since I have so many laying around. I get the same error no matter what. I think it may be an issue with my hardware or a setting in BIOS but I have no clue.

Try to boot the Qubes OS 4.2.2-rc1 installer with kernel-latest.
There is a separate installer GRUB menu entry to run with latest kernel:

1 Like

You can also try to disable Volume Management Device (VMD) in BIOS and change Storage mode from RAID to AHCI if you have it.

You can get the logs from the installer like this:

I already tried installing with the latest kernal but I will try looking in my bios for those settings though I don’t think I have those options. If that doesn’t work I’ll dump the logs for you to seen

I forgot to mention, whenever I try to install with kernel-latest it just flashes the screen a bunch then boots off and restarts at the grub loader. Also AHCI is already set and my laptop doesn’t have a setting for VMD. Though I did solve that issue by changing the bios setting from dynamic GPU to discrete and that seems to allow me into the installer where I’m seeing my current issue. That link also doesn’t really help me. I get a permission denied message when I try to access /tmp/syslog.

You can try to save journal like this:

journalctl > journal.log

And get the journal.log file.

my pc isn’t recognizing the usb when I plug it in after getting the log saved. how should I be doing this? tells me I need to format it. :confused:

Use some USB with ext3/ext4/FAT filesystem. I think exFAT/NTFS are not supported.
Maybe you can copy the logs to the EFI System (FAT) partition of the Qubes OS installer USB.