Need help controlling wireless NIC

I’m trying to test my wifi’s security while learning wireless pentesting. I need to be able to control my wireless NIC. I already know it’s capable of monitoring and packet injection, I just can’t get my kali qube to communicate to my wireless NIC. I downloaded the kali-core template, made an HVM kali qube and enabled the network-manager service (this was part of my trial and error). I’ve also connected my NIC to the sys-net qube, the firewall qube, and the kali qube (not at the same time, obviously) via qvm-pci. My only goal so far is to have my NIC appear when I run the command “iwconfig” in kali’s terminal. Am I missing something? Should I setup a firewall rule to allow the kali qube to communicate with the sys-net or firewall qube?

The command has to be used where the NIC is attached, so if you want to use it inside the Kali qube, you have to attach the NIC to it and proceed with what you want to do.

Switched the pci to the kali qube. For some reason this kali qube (I’ve been through a few trial and error processes) doesn’t have the “iwconfig” command available so I’ll be replacing it with “ip a”. Not that it makes much difference, I still don’t see my NIC. It only shows the loopback and “eth0” which is weird because I don’t have an ethernet connected to the kali qube.

Does dmesg return anything about the device?
Do you see it when you use lspci?

lspci shows the device. dmesg doesn’t. About dmesg: the only thing wifi/wireless related is an error code -2 for a direct firmware load for iwlwifi.

Most likely you need to install the firmware for your NIC in kali template. Search for “your NIC model + error message + debian” and you should be able to find the solution.

Have you been able to use this NIC with another Linux distribution before?
Can you check if your NIC is detected and working on a Fedora-based HVM qube?
Debian is behind in firmware version, especially for iwlwifi (it is 1 year old). So if your card is recent, it won’t work automatically. Can you give the reference of your card?

I installed the firmware; it changed nothing. Thank you for the suggestion, though

I’ve never tried to use the NIC this way in a qube before, however, if I attach the NIC to a net qube I can access the internet. It works with a fedora qube. I need it to work on the kali qube, which is based on debian.

You can try to install newer firmware manually.
Open a qube with internet access and clone the linux-firmware repository:

git clone

Then copy the directory to kali-core:

qvm-copy linux-firmware

Open a terminal inside kali-core, then go to /home/user/QubesIncoming/<qubename>/linux-firmware

Copy all iwlwifi related firmware to the /lib/firmware directory:

sudo cp iwlwifi-* /lib/firmware/

Turn off the kali-core template, start up your kali HVM qube, connect your NIC to it and see if it works.

1 Like

That did it, thank you!

1 Like