My day with Qubes OS

Maybe we should have a thread about our woes, struggles or successes with Qubes OS?

Here’s my story of the day. I was trying to figure out why my commands in /rw/config/rc.local wouldn’t run, I was debugging and running it manually with bash for almost an hour before realizing that it has #!/bin/sh as its shebang.

I was using double brackets in an if statement, and running it manually with bash -x for debugging, and it worked flawlessly besides the actual execution at boot. Eventually I noticed the shebang and saw the [[: not found. :no_mouth: :sweat_smile:

I like the idea of this thread, at least when one is done configuring their initial setup and starting from scratch :sweat_smile:

I am rather new, but was able to lock myself out of Qubes soon after installation, as I probably made some syntax mistake in the rpc config and couldn’t use my keyboard anymore… So I began the whole installation from anew

Luckily, thanks to some friendly users I found out that changing the GRUB options from usbcore.authorized_default=0 to qubes.skip_autostart gives you a second chance of fixing the config problem :slight_smile:


Can you explain what this does? Does it prevent your USB qube from starting, and leaves dom0 with the keyboard and mouse?

As far as I know, it does exactly what you said: not starting sys-usb and therefore connecting the devices to dom0.
I am not sure, if only keyboard and mice or also everything else though. Wouldn’t try it out either, as only the keyboard is necessary (if usb keyboard is needed at all) and I am pretty sure that its strongly recommended to plug out all unused / untrusted devices during startup / shutdown.