My command line comes up with this error message when I try to verify signautres?

I’m on this part: Verifying signatures | Qubes OS

So I have detached PGP signature file and the iso file, both for the same version, in the same folder. But when I run this command:

family-linux@ ~/Downloads/CUBE $ gpg2 -v --verify Qubes-R4.0.4-rc4-x86_64.iso.asc Qubes-R4.0.4-x86_64.iso

gpg: can’t open `Qubes-R4.0.4-rc4-x86_64.iso.asc’: No such file or directory
gpg: verify signatures failed: No such file or directory

Can someone please tell me what I’m doing wrong?

The error message tells you what you are doing wrong.
Either you are not running this command in the directory where you have
those files, or you do not have a file called
Qubes-R4.0.4-rc4-x86_64.iso.asc - perhaps you gave it some other name
when you saved it?

I have changed the filenames, so that they match excepting the .asc extension. But now the terminal only returns a blank.

why would you do this

Srry, it just took a while. Got the results, it’s a BAD Signature.

I’m not supposed to do that? It’s what the instructions told me to do “If the filename of your ISO is Qubes-RX-x86_64.iso, then the name of the signature file for that ISO is Qubes-RX-x86_64.iso.asc, where X is a specific release of Qubes”
Verifying signatures | Qubes OS .

i thought you change the name to something like Qubes-R4.0.4-rc4-x86_64.iso (different extension)

I fixed it sorry, made a bunch of typos and was too impatient to let the gpg program run (it was a bit slow). I got a good signature :slight_smile:

Thank you for biding your time

1 Like