My adventures with Qubes 4.1.1 on a Lenovo T14 Gen 3

Yes, I don’t need to add acpi=off. I also updated to the latest BIOS before installing Qubes and did 1 BIOS update since. Maybe it will be fixed in a BIOS update? I see your model has had 4 BIOS updates since the initial release and mine has already had 8.

I just tried running the installer with

XEN += dom0_max_vcpus=1 dom0_vcpus_pin=1
Kernel += acpi=off

(the installer still fails to run efibootmgr) and then

XEN += clocksource=tsc tsc=unstable hpetbroadcast=0
Kernel += acpi=off

during the “initial setup” – but the setup fails to complete and leaves me with a sys-net that doesn’t start (same as when I had dom0_max_vcpus=1 dom0_vcpus_pin=1 for initial setup).

Guess I’ll just have to keep reloading the Lenovo page - hoping for new BIOS updates … :-/

Thanks for all the tips in this thread, I managed to install 4.1.2 on T14s gen 3 with amd ryzen 7 6850. Used clocksource=tsc tsc=unstable hpetbroadcast=0 dom0_max_vcpus=1 dom0_vcpus_pin=1 xen options during install and boot, and have to use acpi=off kernel options during install and boot. I tried acpi=ht , pci=noirq, noapic, etc but nothing worked except full acpi=off (which implies acpi table parsing code is at fault?). Anyhow in the end internal keyboard and touchpad are not working (even though I can see Synaptics in the lsusb), only external keyboard works (didn’t work with separate sys-usb btw), there are kernel messages suggesting to try pci=biosirq but that didn’t work (either no effect or no boot depending on presence of acpi=off). Also wifi is not working %)
@ChrisA do you have the same problem with keyboard and wifi?
PS updated BIOS to the latest 1.30 before install

1 Like

Unfortunately, my experience is identical to yours: :-/

  • no boot, if I remove acpi=off
  • build-in keyboard/mouse not working

I don’t recall a working WiFi, from my tests - but my focus has been on the “will it boot/install?” and “can I do anything to get the internal keyboard/mouse working?”. Lenovo released an updated BIOS/UEFI for the T14s / T14 Gen 3 2 weeks ago:

for the:

Support model      ThinkPad T14 Gen 3  (Machine Types:21CF,21CG)
                   ThinkPad T16 Gen 1  (Machine Types:21CH,21CJ)
                   ThinkPad P16s Gen 1  (Machine Types:21CK,21CL)
                   ThinkPad P14s Gen 3  (Machine Types:21J5,21J6)

Operating Systems  Microsoft Windows 10  64-bit 
                   Microsoft Windows 11

with the description:

 Version 1.34 (UEFI BIOS)(Machine Types:21CF,21CG,21CH,21CJ,21CK,21CL,21J5,21J6)
         1.25 (ECP)
[Important updates]
- N/A

[New functions or enhancements]
- N/A

[Problem fixes]
- Fixed an issue where tpm can't to change from DTPM to pluton when WMI set bootDisplay to ExternalDisplay.
- Fixed an issue where system cannot auto set the security chip to Discrete TPM after disabling the Microsoft(R) Pluton Processor Control when manual set security chip to MSFT Pluton.
- Fixed an issue where Security chip item show 8 lines on BIOS setup in Simple Text mode.
- Fixed an issue where srsetup tool can't set to Discrete TPM when security TPM select set to Pluton on BIOS setup(srsetup /z /dtpm).

It doesn’t look like it changes much wrt the issues we have - but I’ll try it and see (pending time for fun) …

Edit: My attempts to update the ECP, has so far landed me pretty much on:


ftr situation with wifi : after installing latest firmware (I copied firmware-atheros 2023smth deb package from debian testing via usb stick) the card initializes but then dies with the same log as in QCNFA765 (wcn6855) WiFi6 controller not working

re keyboard issues there is this Include patch fixing Ryzen 6000 Keyboard by dylangerdaly · Pull Request #614 · QubesOS/qubes-linux-kernel · GitHub which to me reads as the issue with same symptoms was fixed in some way and the fix is included in kernel-latest… @dylanger any chance you can comment on this please?

I’ve tested version 4.2.0-rc3 without any success.
Not tested any changes in boot options, but the installation media won’t show any graphical UI during boot.

I’ve tried with all the XEN and Kernel options discussed earlier in this thread, but I can’t even get the installation to boot correct. Any other tried with success?

Hello, @ChrisA did you always have the ISO file with acpi=off? I’m also running on a ThinkPad T14 Gen 3 AMD, and I would like to try Qubes OS. However, I’m not very good at kernel compiling.

Thank you very much for your help. Helphy

I’ve not had the time to play around with Qubes OS 4.2 and the T14 … so it might be better now - and it might be the same still … :-/

I added the acpi=off to the GRUB settings - so I didn’t have to recompile the kernel - “just” to set some boot options.