My 64gb kioxia USB isn't detected

guys i need your help please when i reach the installation process of qubes os, the os can’t detect the second usb of installation it only shows the ssd disk. what’s wrong and how to fix please? btw :
pc: dell latitude 5590
os version: 4.2.1 (the latest)

Just to make sure, you have 2 USB disks: first with Qubes OS installer and second where you want to install Qubes OS on?
You can check the disks detected in your system and search for errors in log as I’ve suggested previously:

i tried that bro but a lot of writing showed up i didn’t understand a thing, i didn’t write anything cuz i was afraid to screw things up

i just want to understand why installing this os is so hard man!!! a problem after a problem

Can you answer this?
To make sure that you’re not trying to install Qubes OS on the same USB disk that you use to boot Qubes OS installer.

Yes… i have 2 usb one that i boot from(kingston 8gb) and the other one is for installation ( kioxia 64gb)

I’m not sure if it’s relevant in case of USB disk, but you can try to change SATA mode from RAID to AHCI in BIOS.

I just checked sata operation on my bios setup and it’s already set to ahci

You can try clicking on “Refresh…” at the bottom right of the Installation Destination screen, maybe you’ll see your disk after this:

1 Like

Just tried that and nothing:

What to do bro :cry:

You can check the output of the commands from my post in another topic.
If you don’t know what to check then you can make a photo of the commands output and post them here.
Or you can get the installer log using this command:

journalctl > journalctl.log

Mount your internal disk and copy the file there:

mkdir /mnt/mydisk
mount /dev/sda1 /mnt/mydisk
cp journalctl.log /mnt/mydisk

Then upload the log here.

1 Like

Bro i tried open the terminal but it’s scares the hell of me,cuz i don’t understand anything plus i wrote this before and it gave me a long list to scoll it up and down and whenever i press something i start beeping loudly, so i just quit.
Anyway this is start to be a pain in my @ss , since I can’t just select the usb easily then it seems i have no chance downloading this os ever😔.