Move files to running disposable VM


I want to move files to a running disposable VM which I use for browsing.
I need to upload files with my browser and I don’t see how I can access them from my disposable VM.

When I try to copy the file through “Copy to VM” there, it does not work.
Is there a way to accomplish this?


are you copy file to disp(some number)?

That does not seem to be an option in the drop down menu when I right click and try to “Copy to VM”.
I can only pick Target: Disposable VM (whonix-ws-16), not the running one specifically.
It does not work like this, unfortunately.

Is there a terminal command I could use?

let’s try to fix the gui first

anyway, if you can’t screenshot, here the command

you could also use dom0 method

qvm-copy-to-vm <target_vm> <file>

An existing disp1234 is not going to be listed at the top like “Disposable VM (something-dvm)” - those entries are for spawning a new DisposableVM based on something-dvm. Look further down, as if it was a normal VM starting with the letter d.


This is for moving from dom0 to domU.

For copying from domU to domU qvm-copy is used in the source VM terminal. example:

qvm-copy <targetVM> /path/to/file.txt

However, this results in the same GUI popup that requires mouse interaction. There are ways to modify policy settings in dom0 to allow domU qvm-copy commands but I couldn’t get them to work in 4.1. Maybe I need to restart Qubes?

Hey, I prefer not to take screenshots of my system for the general public.
The drop down menu displays all templates and VMs excluding the currently running disposable VMs.

When I try this terminal command

qvm-copy-to-vm disp88 sample.pdf

This happens:

user@host:~$ qvm-copy-to-vm disp88 sample.pdf
qvm-copy-to-vm/qvm-move-to-vm tools are deprecated,
use qvm-copy/qvm-move to avoid typing target qube name twice
Request refused

When I use qvm-copy, as the terminal suggests:
The command results in the same GUI popup that requires mouse interaction, as @necker said.

so did it solved?
because you put your anonymity too high, i can’t help you further if it won’t work

Do you know how to use terminal from domU to domU without the need for a mouse/GUI window?

@ralf_meyer This might help if you are using Qubes 4.0

There is a different way to do it in 4.1 but I can’t find it right how. Neither method worked for me though.

Here it is…

(but again, I’m running 4.1 and I and the above did not work)