Mouse problem

Hello guys, I installed Qubes 4.1.2, everything is normal except the mouse does not work. It is a wireless mouse. I connected a wired mouse, but the problem was not solved.
Any suggestion?

Have you followed the steps for USB mice? I’m assuming that you’re using USB for your mice.

No, because I can’t open the terminal and use the system without the mouse

I’m not at a computer currently but you should be able to press alt+f3 (or maybe it was f2) to open the app finder. Type in “terminal” (without quotes) and you should be able to select and open the dom0 terminal.

Alt+f1 can also open your application menu but it gets stuck if your hold it too long. So, I recommend the F3 (F2?) combo.

Is the keyboard:

  1. Build in (a laptop?)
  2. External (via PS2)
  3. External (via USB)

… and was the mouse connected when you installed Qubes?


I will try this method and tell you the result

Yes it was connected during installation

I’m guessing that you installed a USB Qube during installation. If that is the case use this then follow the doc for USB mice.

Thank you everyone. I tried to fix the problem, but it didn’t solve the mouse. It doesn’t work. The keyboard doesn’t work, even though it works with a wire. So I went back to Manjaro.

Out of curiosity, how does the wireless mouse connect?

  1. it uses a USB Bluetooth dongle
  2. it connects directly to your system using Bluetooth

Afaik, the 2nd setup will not work with Qubes OS.

They did not answer anyone’s questions about the type of mouse/keyboard, and they never mentioned what steps were taken for troubleshooting. Doubt they read the docs either.

1 Like

What do I do when these appear

I cant see that image.
Give a summary.

@unman The image is a screenshot that displays a [dom0] Operation execution dialog that asks the user to allow (or deny) a qubes.InputMouse operation from the source sys-usb to the targey (apparently prefilled): dom0.

@gonzalo-bulnes Thanks

@kaaled - Short - Select the “OK” button

Long explanation:
When you set up a sys-usb USB devices are attached to that qube.
This means that your USB mouse is detected in that qube, and mouse
movements are detected there too.
Qubes has a mechanism for making those movements available to the system
as a whole.
It’s most likely that you are using dom0 as the guivm, controlling over
all what you see on the screen.
The dialog you see is asking if you want to allow mouse movements
detected in the sys-usb to be available to dom0, and so the system as a
whole. You want to say “OK”.

Exactly the same process applies to USB keyboards. By default key
presses will be restricted to sys-usb. You can configure a policy to
allow those presses to be passed through to dom0, and so available in
all qubes on the system.

I hope that is clear

I never presume to speak for the Qubes team. When I comment in the Forum or in the mailing lists I speak for myself.