Mouse movement issues

Hello everyone since 4.0 I’ve been having random mouse issues were my mouse suddenly goes really slow and laggy. The “Solution” i use is to unplug my usb mouse and plug it back in to reset it.

Some things to consider

  • I’m using a razor mouse
  • Happens in all Qubes
  • I’ve noticed it happens a lot when click in type boxes or search bars, typically when i’m writing notes as well .(it happened multiple times typing this post out)

Do you have sys-usb qube? Anything relevant in its logs? Did you try to give it more RAM?

i do have a sys-qube and it has 1048 mb of ram, the only thing i see in the logs which im not sure of is
“hid-generic 0003:1532:0084.0082: control queue full”

Is the “control queue full” log spammed in dmesg (in sys-usb) when your lag is occurring?

I did some testing to try get it to lag then check the logs and yes multiple time the logs have “control queue full” spammed

Can you run sudo dmesg -n err in sys-usb and see if it changes anything?

i ran the above and well i haven’t had the issue yet, i’ve been trying my best make it happen but i’m not 100% that it solved the issue, more like its a matter of time before it starts playing up again

Just wait and see if it happens again. If your sys-usb is disposable, remember to rerun the command when you restart Qubes.

This happens to me too when I enable Caps Lock. I just have to restart sys usb.

Do you have the same log spam in dmesg?
If that’s the case, can you try the command I shared earlier and see if it changes anything?

1 Like