Mistakenly added video controller to auto-booting vm. Now no video output for dm0


I’ve made a stupid mistake. I added the video controller to a auto-booting vm. Now everytime I boot, the vm grabs the video output and I can’t see anything. Is there a way to disable the auto-boot option before booting?
Sorry for my stupidity, I’m complete new to qubes.

What is the qube that is autostarting?
You can boot in rescue mode by changing boot parameters in grub to
include systemd.unit=rescue.target - once you are logged in you can
change the allocation or delete the offending qube.

It’s a debian-10 vm I created. I run qubes 4.0.4.
How exactly and where do I have to change the parameters? I’m not familiar with this.

Thanks now I’m in rescue mode logged in as root. Where do I find the config file for the problematic vm to disable auto-boot?

sudo systemctl stop qubes-vm@<qube name>
sudo systemctl mask qubes-vm@<qube name>

1 Like

Thank you very much, that solved it.

1 Like