Minimum specs/Hardware recommendations for a usable experience?

I have just installed Qubes 4.2.1 on my HP Elitebook 820 g1, in legacy BIOS mode. It has an i7 4600u, 16gb DDR3, and a 256gb SATA SSD. Vt-x and Vt-d are enabled. I verified the ISO from multiple keyservers, on different PCs and networks. Followed the official installation instructions to the letter. There were no errors during the installation process, and the system boots as expected.

The problem is it’s completely unusable, even with just dom0, default service vms, and sys-whonix running. Keyboard and mouse input are inconsistently delayed, opening the Qubes app menu can take up to 5s each time (navigating it is very painful). Dragging a window is very slow and occasionally freezes the whole system for a few seconds. In Firefox, in the default Fedora or Debian disposable, basic interactions such as right clicking or even scrolling are incredibly laggy and slow. I tried YouTube as well, and even at 360p windowed I was getting constant frame drops.

Before trying Qubes I had arch installed with KDE Plasma, and the system was completely usable. Obviously Qubes is much more demanding with the amount of VMs it has to run. To be honest though, I did not expect much better from on this incredibly weak, dual core CPU. The only reason I even tried on this computer was that other people seemed to be having success with similarly specced machines, at least from what I could find though my preliminary research.

I love the idea behind Qubes, and I’m sure the performance is sufficient on better hardware. I don’t expect something like this to be super snappy and responsive, especially load times when booting VMs. However, I am not sure exactly what specs I need to have a usable experience for basic web browsing/email/office tasks. The official system requirements only list 16gb ram, 128gb SSD/NVME, and a 64 bit CPU with VT-x, VT-d, and EPT. I couldn’t find anything on actual CPU specs (model, core count, clock speed, etc.) though.

I checked if my laptop was on the HCL, which it is (as of v4.0 at least). I also had a look at the Qubes certified hardware for clues, but the ThinkPad x230 is on there, which has a worse CPU than mine! So, either that list is outdated, or maybe I just have unreasonable expectations and most people somehow get used to the extreme lag.

I am still very interested in trying out this (really cool sounding) OS on some better hardware in the future, once I can afford it. If I could get a recommendation for a laptop that can run Qubes at an acceptable (even just “school chromebook” levels of performance would suffice for my needs), it would be very much appreciated!

(On mobile rn, apologies)

1 Like

I am using the exact model. With even less RAM (12GB) and slower CPU (i5-4300U). The drive is an M.2 SATA. Here is the HCL report:

brand: |
model: |
  HP EliteBook 820 G1
bios: |
  L71 Ver. 01.47
cpu: |
  Intel(R) Core(TM) i5-4300U CPU @ 1.90GHz
cpu-short: |
chipset: |
  Intel Corporation Haswell-ULT DRAM Controller [8086:0a04] (rev 0b)
chipset-short: |
gpu: |
  Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 0b) (prog-if 00 [VGA controller])
gpu-short: |
network: |
  Intel Corporation Ethernet Connection I218-LM [8086:155a] (rev 04)
  Intel Corporation Wireless 7260 [8086:08b1] (rev 73)
memory: |
scsi: |
  HGST HTS545050A7 Rev: AC90
  TS240GMTS420S    Rev: 1A0 
usb: |
  - works:
    qubes: |
    xen: |
    kernel: |
    remark: |
    credit: |
    link: |

I made few tweaks. Installed fedora-minimal template and installed packages for sys-net, sys-usb & sys-firewall on it. Switched the mentioned servicevm templates to it. Reduced initial RAM for sys-usb, sys-net, sys-firewall, sys-whonix to 400MB. Reduced maxmem for sys-firewall to 400MB. Reduced maxmem for sys-whonix to 1GB. Disabled sys-whonix autostart by default. It will autostart as soon as I launch an App from anon-whonixor whonix-dvm

Here is the list of Qubes certified desktops and laptops.

Please be advised that GPU acceleration is not available by default (at this time). You could not expect the same KDE or media playback you get from a regular bare-metal Linux Distro.


I just tested with only dom0, and it was still just as slow. Installed some test apps such as LibreOffice directly to dom0, then disabled all other VMs on boot. (I know this is very insecure, I was just doing it to test.) Not quite as bad but still unacceptably slow. Is there some config step I missed? Or are you just extremely tolerant of lag?

1 Like

Check the CPU usage in dom0, what processes are loading the CPU and what’s the load?

1 Like

The only difference I might think of is the firmware version. Before installing Qubes, I upgrades the firmware to the latest version (available in the HCL report).

Even before the tweaks, never got 5s delay on Appmenu. I would suggest to check the running processes and the CPU temperature.

1 Like

Thanks for the help! The CPU was spiking to 100 whenever I did anything graphical which made me think it might be a GPU issue. I tried reinstalling with kernel-latest and that fixed the issue!


Glad that it is working. I would check the fan and vents as well. These laptops has been serving us for a long time. Dirt and dust might block the vents sometimes.


I did do that as well as a repaste. One thing I forgot to mention is I’m getting screen tearing while scrolling which I didn’t before, but at least the system is usable now.
Btw sorry for my slow replies. I’ve been quite busy with some other stuff and haven’t had much time for this over the past couple days.