Minimal Template install failed

Hey everyone, I got the same error all the time when I try to install a minimal template (fedora or debian)
I run the command : sudo qubes-dom0-update qubes-template-fedora-34-minimal or sudo qubes-dom0-update qubes-template-debian-11-minimal

It launches the installer and after few minutes arround ~30% of the install it failed with this message :
Error canonicalizing file: Payload forged!
ERROR: [Errno 2] No such file or directory: ‘/home/user/.cache/qvm-template/tmp0otbya9v/qubes-template-fedora-34-minimal-0:4.0.6-202110020922.rpm.UNTRUSTED’

The “Payload forged” error comes from rpmcanon, and means that the RPM package’s payload failed to verify against its cryptographic signature or signed hash. rpmcanon interprets that as an attacker having attempted to replace the intended package with a malicious forgery and gives this error. That said, a far more likely cause is that the package was corrupted for completely mundane reasons, so this is a rather misleading error message. In particular, any problem that causes the package download to be interrupted after the package header has been fetched will give this error. By far the most likely cause of this is a temporary network error.

As far as solutions go, I recommend making sure that your network connection is stable, or just retrying a few times. I filed Bad error message when a template download is interrupted · Issue #7375 · QubesOS/qubes-issues · GitHub for the bad error mesage.

Yes that fixed my issue, I have a VPN on my router and I think the connection wasn’t stable sometimes, I connected directly to my ISP (no choices) and it work.