Minimal debian qube associate pcmanfm for file manager/picker

I have a minimal debian-11 qube. I have installed many packages from debian repository into it. You know, many terminal applications, libreoffice itself, recommended qubes-os functionality packages, etc. Basically, I have made it my custom debian setup.

I am trying to run Cura Ultimaker 3D Modelling software on an AppVM based off of this custom debian template I have. Cura runs OK. I am able to get to the Cura GUI etc. etc. However, one kink I am trying to iron out on this qube is getting the file manager I have installed, which is pcmanfm, work with the Cura’s file picker. You see, when I try to “Open File(s)…” from the Cura’s GUI, nothing pops-up. I want to get pcmanfm window to pop-up and let me pick a Cura-compatible design file to open.

I have tried following stuff to get the templateVM associate pcmanfm with the default file manager:

(template) $ xdg-mime query default inode/directory

Also, I have added the following 3-lines to /etc/xdg/mimeapps.list file:

(template) $ ls -la /etc/xdg/mimeapps.list
-rw-r--r-- 1 root root 91 Feb  7 16:19 /etc/xdg/mimeapps.list               
(template) $ cat /etc/xdg/mimeapps.list               
[Added Associations]

Also, I have manually created and added the following line to /usr/share/applications/mimeinfo.cache file:

(templeta) $ ls -la /usr/share/applications/mimeinfo.cache
-rw-r--r-- 1 root root 45 Feb  7 16:29 /usr/share/applications/mimeinfo.cache
(template) $ cat /usr/share/applications/mimeinfo.cache
[MIME Cache]

As you can see, I have tried everything in my knowledge to get Cura Ultimaker program use pcmanfm file manager for “Open File(s)…” and/or “Export…” functionality (which are supposed to pop-up the file manager and let me choose the name/location of the files to open/export). However, I have failed in achieving that.

Any recommendations from people who are knowledgeable about file type associations/mime stuff/dbus stuff on Linux?

Weird thing is, on the same custom debian AppVM, within the Librewolf browser, the “Open File” dialog (Ctrl+O) already brings up the GTK (?) file picker dialog (and not the pcmanfm). I wonder why Cura cannot bring up the same GTK (?) file picker :thinking:

You should start by the beginning.
You have a filechooser problem with Cura Ultimaker.

Those two links give you github issues in the first results.

For a more global global view:


Hey, thanks. I have installed zenity package, which pulled in a bunch of dependencies, including xdg-desktop-portal and xdg-desktop-portal-gtk which this post suggest for a solution.

Now I have a open file/export etc. file picker dialogues available for use. I guess I didn’t need pcmanfm package at all, lol. I will remove that and delete my mime modifications. Thanks for linking me to proper github issues.