Menu touble with Debian 11 Disposable VM

Running Qubes 4.0, not 4.1

Googling seems to suggest this is a common problem, but it doesn’t highlight an answer beyond what it is in the docs (Disposable customization | Qubes OS)

I had a disposable VM set up using Fedora-34. It was set up by cloning Fedora-34 into fedora-34-dvm, setting the flags and running the qvm-features appmenu-dispvm 1 command.

All good - I can generate disp vms on the fly through the menu.

However, for some reason I can never get BBC Sounds or other streaming programs to work in Fedora easily.

I cloned debian-11 to debian-11-dvm, set the flags as per the docs, removed fedora-34-dvm and ran the appmenu-dispvm 1 command. However, I can’t get a disposable option to appear in the menu. I can only see Domain: debian-11-dvm

Weirdly, when I ran qvm-features debian-11 [NOTE NOT THE DVM TEMPLATE] appmenu-dispvm 1 then a bunch of my debian qubes turned into disposables. This confused me (because why does the command work for debian-11 but not for debian-11-dvm) and it took a little while to figure out how to undo it.

I can start a disposable dvm using debian-11-dvm from the command line and that works fine, so the qube is configured correctly. It just seems that I can’t get a debian based disp vm to appear in the menu, I can only access the template.

Any advice?

Are you sure you cloned it, or you first created AppVM based on debian-11 template, and then flagged that AppVM as disposable template?

qvm-create

Perhaps the latter, I had assumed it was a clone

Well then, do these topics give any clue?

If not, then I’m afraid someone with more knowledge could try to help you.

I think I have found the issue.

Looking back through logs, when I try and invoke the command:

qvm-features fedora-34-dvm appmenus-dispvm 1

I can see this error:

Feb 01 21:15:14 dom0 qubesd[2012]: xdg-desktop-menu: file '/home/redacted/.local/share/qubes-appmenus/fedora-34-dvm/apps/fedora-34-dvm-qubes-start.desktop' does not exist
Feb 01 21:15:14 dom0 qubesd[2012]: Problem creating appmenus for fedora-34-dvm

For some reason the fedora-34-dvm-qubes-start.desktop file isn’t there.

I guess this is a bug, but could someone tell me what I need to create the missing file?

This is the fedora-34-qubes-start.deskstop, what do I need to tweak for the disposable one?

[Desktop Entry]
Version=1.0
Type=Application
Exec=qvm-start --quiet fedora-34
Icon=appvm-black
Terminal=false
Name=fedora-34: Start qube
GenericName=fedora-34: Start qube
StartupNotify=false
Categories=System;X-Qubes-VM;

Thanks

Do you have trouble with debian-11-dvm or fedora-34-dvm? In the opening post you said that after running the command for fedora-34-dvm

what did you mean by removed fedora-34-dvm? If you mean from the default disposable template for debian-11-dvm, I don’t find it necessary. I still have it there, because it is global default.

Did you try to create debian-11-dvm via GUI from the Qube Manager → New Qube → Type: AppVM, Template -debian-11, Launch settings after creation - Advanced tab - check Disposable template - OK?

(you may edit the topic title, a “r” is missing in “trouble”)

I had skipped a few steps in my response. But yes, I have followed the manual. Many times.
The DVM works when launched by command line, it just doesn’t turn up in the menu.

The issue appears to be menu specific, not DVM template specific.

As to the references in the above code to Fedora-34-dvm, I had removed the Debian DVM and created a Fedora-34-dvm in case the issue was very specific to Debian and would resolve when Fedora returned. It did not.

Hence the log hunting, and hence the above error.

Can anyone (veiled plea for the oracle that is @unman perhaps!) let me know what should be in the -start.desktop file?

Or am I down the wrong road?

Thought it had been fixed - but it hadn’t. You can ignore this.

Did you try to set debian-11-dvm as default disposable template for debian-11-dvm?

Yes, I had done that.

I upgraded to 4.1 last night, so hopefully that is the end of the issue.
I may also just go with Fedora and see if I can get audio to work properly.

Sorry to hear. I get disposable: menu entry even for windows disposable template. So I guess it was something with creating debian-11-dvm.

Hopefully you won’t have these issues wit 4.1 stable.

I have a fresh install of Qubes 4.1 and I am missing the “Disposable: debian-11-dvm” entirely.
I do see a template “Template (disp): debian-11-dvm” though.

What is the correct way to get the “Disposable: debian-11-dvm” to appear?

If I manually create a qube with the debian-11-dvm template I end up with a menu entry “Qube: …” and not “Disposable: …”. Is that significant? I’m a little lost.