Maybe x230 is getting too old for qubes...?

I have hesitated to make this post, but there’s enough that’s happened now to make me wonder about my hardware.

I have an Lenovo x230, good brand SSD and good brand 16G memory. Coreboot and MECleaner are installed and I’ve run Qubes for several years (back to 3.1, I think).

I got this as a “refurbished” machine - it wasn’t refurbished, it was filthy and it looked like it had been treated like a weapon in a pub brawl. I exaggerate, but it wasn’t great. I cleaned it up and ‘got on with it’.

Recently there have been a couple of funny glitches in 4.2 that have just popped up.

There have always been a few oddities in previous versions. I usually attributed it to my own ignorance, which is substantial.

Still, I wonder if there is something odd happening at the hardware level. I wonder if its failing. I don’t know if 16G is enough for Qubes 4.2 - not only for performance (for which it is pretty marginal), but also for faithful operation of all the system operations that create a reliable desktop system.

On the other hand, maybe its just a dud, damaged x230.

I know old hardware has its value with Qubes/Coreboot/MECleaner, but I just want to flag this strange behavior for anyone else looking at the x230 workhorse for their own foray into Qubes.

Curious to hear from others with x230s.


I used to use one, with QubesOS. Coreboot, 16 gigs of ram, the whole shebang… However, I got a hold of NV41 recently, and man, 64 gigs of ram, plus a modern CPU is a blessing. Especially when watching 1080p videos, I no longer have my cooler fan spinning like helicopter.

One can certainly use QubesOS with x230, but he will mostly have to use lean programs and terminal applications, imo.

If you run the bare minimum of VMs… Its still not enough. I’d also recommend to go with one of the qubes certified laptops. The x230 is just to old. Unless you only run something like sys-net sys-firewall sys-vpn sys-whonix anon-whonix, I don’t think it’ll be much fun.

Yeah, I’ve put up with the glacial speed for some time. You do adjust, just trim your expectations.

What I am unnerved by is - what seems to be - system instability. And the fact it seems to be increasing. I don’t know if that indicates a decay, or if its the demands of 4.2 (which otherwise seems much smoother).

1 Like

The x230 is one of the certified laptops.

It might not be enough for everyone, but it will run Qubes OS just fine.

1 Like

I don’t have this weird mouse problem you are describing. But i generally agree, it’s getting old. I used minimal template for everything, but to no avail. Slow boot/qube starting times and videos are only possible on invidious, if at all. I currently use a t440p to bridge the time until i have the money for a nv41.

1 Like

ah yes - I meant the new ones.

Certainly the x230 is getting old. I run one, and know a number of
people working with them and x220s. I cant speak to the 1080p videos,
but I dont recognise any of the issues @gidgrun reports.
So yes, I would suspect dud hardware in that case.

I do work with minimal templates, and tweak the system to reduce load
on the RAM. But no more than I do on any machine with 16GB. Otherwise
the x230 remains an affordable workhorse, which runs Qubes fine for most

Any one who would like to work with Qubes should think about what
applications they want to run, and how they want to run them, before
buying hardware. This sounds obvious, but it isnt done.
Buyers should always do some research to check that Qubes is a match
for their use case, and their hardware is a match for Qubes used in that
way. It’s surprising to me how many people dont do this.

I never presume to speak for the Qubes team.
When I comment in the Forum I speak for myself.

I should say, the old girl has gotten me through 5+ years (including external coreboot flashing).

Feeling sentimental now… [sniff]

But in truth I suspect people like yourself, @unman use Qubes with a different workflow than mine: maybe I’m less structured, less task-oriented (this machine is usually just fine doing one thing in one qube). I think use case, which isn’t always easy to define, really does indicate the adequacy of the 16G machine.

But nothing explains those glitches.

Another one: I have a default-dvm and a default-dvm-wifi. All disp-vms launched from default-dvm are listed in the Applications Menu under default-dvm-wif. Always. (I’ve checked, they don’t have wifi credentials).

This is where I struggle - how could a hardware fault deliver such specific, durable, almost-elegant faults? Weird.

It’s this issue:

1 Like

I agree with you guys.

A X230 lets you do basic daily stuff, like chatting, browsing and office stuff maybe.

X230 gets hairy when you do Win-based HVM stuff, and updating them at the same time.

For the average Lenovo-Lover T440P and W541 should be considered as follow-ups.
The T440P needs some facelifting like with the trackpad but otherwise is a decent device.
W541 on the other hand takes 32G RAM which is quite okay-ish (better than 16G in T440P) for Qubes.

They tend to be affordable from ebay and the like.

Major point for them is instead of 2C/4T they do 4C/8T, which is a lot beefier for Qubes purposes. (NOTE: you’ll at least need a 4800MQ because of VT-d)

But these devices handle the workload good enough to do stuff beyond basic/ office usage.

1 Like

X230 has worked fine for me for a long time with only minimal problems. I will admit the AV quality left something to be desired, but that’s not a big deal in the grand scheme if it isn’t your profession. I upgraded for a few reasons, one of which being when I saw a qube took 4000M in the domains widget, I thought it actually took 4000M. This isn’t the case. If you minimize your RAM usage, you can get quite a few VMs running in parallel.

1 Like