Lost Access to Desktop Environment (Up to $500 Bounty)

Hello,

Initially posted on the Qubes-issues repo but was redirected here. Would greatly appreciate any help as I am working on a project and unfortunately have not backed up in a week :frowning:

My machine:

Qubes 4.1
Coreboot 4.14
Purism Librem 15v3
Intel Core i7

What happened:

I was working on my machine, when all of a sudden my screen lost all the surrounding Qubes GUI/icons.

Because new users are restricted to one media attachment, please see the initial GitHub post for screenshots of the issue as well as the logs. (Sorry!).

I greatly appreciate any help.

Thank you!

$250-$500 bounty!

If you’re able to open a terminal, try to run xfdesktop -R.
You might have to run it as root.

If that doesn’t cut it, try removing ~/.config/xfce4 (or move it somewhere else: mv ~/.config/xfce4 ~/xfce4-bak) and reloading the settings with the command above.

I’m not sure either, but i’d like to know your dnf history

Could it be related to this? panel is gone: "failed to show the preferences dialog" · Issue #7358 · QubesOS/qubes-issues · GitHub

Also:

@deeplow I thought so too, but if you look at the last few pictures, I tried the xfce4-panel command with no luck

1 Like

@BEBF738VD and @51lieal here are the results from your suggestions/requests:

I am still getting the same error that I did with all other attempts

Unable to init server: Could not connect: Connection refused

Thank you for everyone’s help so far!

If you can access xfce4-settings-manager, try changing the output for panel.

I had a similar issue, after a firmware update, and changing the output solved the issue with panel crashing.

Unable to init server: Could not connect: Connection refused
xfce4-settings-manager: Cannot open display: .
Type ‘xfce4-settings-manager —help’ for usage.

Maybe I should add that right now, the only way I could think of to bring up a terminal is to use the shortcut ctrl+alt+F2, which brings up the virtual console where I then need to login to Dom0.

When you boot into the empty desktop, use the windows content menu key (the microsoft windows shortcut keys). That should allow you to open a dom0 terminal, and from there you can open the settings manager.

Or hit alt+F3 and type “terminal”.

@renehoj I have a Purism Librem laptop, so no windows key

@fsflover That worked great! It actually brings up an Application Finder, where I can open any app in any Qube, including any System Tools or Qubes Tools (update, backup, etc).

I opened a Dom0 terminal, and I was able to open the xfce-settings-manager.

Selecting Panel shows this error:

Selecting ‘Desktop’ shows that icons and menu is selected, but it results in an error in the terminal

(sorry for posting multiple times - I am limited to one attachment per post).

What error do you get when you start panel from the command line?

That fixes it!

However, I can’t interrupt it or close the terminal, or the panel disappears again. Do you know of anyway to fix that? Not a big deal because I could just start it at each boot up.

So @deeplow had the right idea from the beginning, I just wasn’t opening the terminal correctly. @fsflover showed me how to do that, and renehoj brought us home (I can only mention 2 users in a post). There really wasn’t one person who can claim all the credit.

I think $200 each for a total of $600 is fair. You can dm me a Bitcoin address or venmo/cashapp, whichever you prefer.

Thank you so much! I’m very relieved

4 Likes

@renehoj brought us home! :blush:

Thank you! Can you donate $200 on my behalf to Qubes OS and post a confirmation here? :wink:

5 Likes

Absolutely! Thank you for donating!

Yoooo, this shit is pissing me off. Won’t let me attach my signed file and copy/pasting it invalidates the signature for some reason. Download from dropbox sorry:

5 Likes