Losing It Over OwnCloud Install

I had owncloud 2.7 installed. 2.9 came out. i may have ran install instead of update when i did sudo dnf (install/update) owncloud

i got an error

[SKIPPED] owncloud-client-2.9.0-5150.x86_64.rpm: Already downloaded            
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'
Error: Transaction test error:
  file /etc/ownCloud/sync-exclude.lst from install of owncloud-client-2.9.0-5150.x86_64 conflicts with file from package owncloud-client-libs-2.7.4-2.fc34.x86_64

i then uninstalled owncloud completely, tried agan, same error

tried apt-get -o Dpkg::Options::="–force-overwrite" install owncloud-client, it doesn’t work

tried sudo su and going into thunar to delete all the owncloud files already there, didn’t work and there’s no 2.7.4 file anywhere.

this is destroying me

fedora34 template

tried a dnf clean but nothing

i don’t know what i did

i can’t find owncloud-client-libs-2.7.4-2.fc34.x86_64 anywhere, i don’t know how to get rid of it or the error, i’ve done many searches.

This looks like not a Qubes-specific issue. Qubes OS simply runs virtual machines and does not normally deal with their internals. You may have a better luck asking Fedora or OwnCloud community.

Otherwise, consider restoring your backup of the VM (you made it, right?) or using qvm-volume revert.

This is very confusing. You mention apt-get (were you installing it in a Debian template?), Fedora 34 (or in a Fedora template?), and then the error message looks like something that could happen when updating dom0. I suggest you read more about Qubes (see the docs) to understand how things work in Qubes. Perhaps you installed it in a disposable VM and now it’s gone after you rebooted it.