Locked USB keyboard sys-usb luks

Hello,

After manually creating sys-usb qube, restarting OS, now unable to use USB keyboard to enter passphrase for luks. These steps appear not work as I cannot reach settings.

This appears to work but not sure how to do.

Thank you. Intel Nuci5FNHCA.

Did you do this?
sudo qubesctl state.sls qvm.usb-keyboard

Where I could, no. Can do it now some place?

Dont think so, reinstall and us ethe above command and the usb keyboard with work during unlock.

@abc I can just confirm @anonymous.

Do YubiKey not Detected in Device Manager (USB-keyboard enabled) also worked for me (I am also using a NUC :wink: )

No need to reinstall - thatā€™s absolutely the last resort.
If you are using legacy boot, then you can interrupt boot, and edit
boot parameters to restore the USB controllers to dom0.
Dont know what the equivalent would be for UEFI, if there is one.

Otherwise, boot from installer, get shell and edit the parameters there.
If necessary hobble sys-usb to avoid it starting and stealing the usb
devices until you are ready.
This has been covered on the mailing list a number of times - search the
archives.

If you need more help, post whether you are UEFI or legacy boot, and
what level of Linux knowledge you have.

1 Like
  • Legacy boot:

    1. At the GRUB screen, hit ā€˜eā€™, then remove rd.qubes.hide_all_usb, then boot
  • EFI boot:

    1. Start with a LiveCD, mount your ESP FAT partition
    2. edit: EFI/qubes/xen.cfg
    3. note what the default= kernel is
    4. edit the kernel pointed at by default to remove rd.qubes.hide_all_usb
    5. reboot without LiveCD
  • That will allow typing your disk encryption password and logging in. Then, reconfigure sys-usb:

  • qvm-remove sys-usb

  • sudo qubesctl state.sls qvm.usb-keyboard

    • This will recreate sys-usb AND enable USB keyboard login
2 Likes

My understanding is very little, beginner. Solutions appear to work but did reinstall Qubes. Apologies.