Liteqube Failed 4.1

Hello, I need help installing Liteqube.
I realize that this may be an off-topic question, but I’m having trouble with github.

I installed the 1.Base script from Liteqube, it created a “debian-core” template and nothing else, then I proceeded to install 2.Network, and when running install.sh it says “core-dvm” and installation stops, the same with 3.USB, etc.
I tried to create the core-dvm cube manually, but I get the same message.

Maybe someone has encountered this? Thanks in advance

I was able to create a Github account, and I posted this problem in the Liteqube repository, but I seem to have been marked as a “Spammer” and hidden from the rest of the world.
https://github.com/a-barinov/liteqube/issues/3

The script fails, the solution is install the 1base … Install.sh … two or three times without deleting nothing in a row until it ends without error, then the next the same … 2 or 3 times, But take care of USB … If you don’t configure first the usbguard in the config of the USB liteqube installer … The keyboard will be banned if you have and USB keyboard and the mouse too … And you must need to restart and follow the same principles as is sys-usb fails to recover from it

Every installer must be run multiple times until there is no error, and don’t delete the qubes that it tried to config … It will finish ok and the third or so

1 Like

I think that the problem with the installer is that is written in a sh script and it has some kind of timeouts between commands

1 Like

Thank you for your instructions.
I uninstalled debian-core for tests to try to install it again, so for your instructions I reinstalled my Qubes 4.1 test system to be safe.
But I keep getting the same errors, I have many times typed ./install.sh but I keep getting the same message:
UNKNOWN TYPE OF ./debian-core/protect/template.ALL/home/user/.config/autostart, EXITING
And when I try to run the 2.Network installation many times, I get the following:
ERROR: core-dvm NOT FOUND, PLEASE RUN BASE INSTALL
I only have debian-core among my cubes and I haven’t noticed any others.
I’m trying to figure out the installers code to solve the problem.
I will be grateful if you can tell me how to fix it :slight_smile:

Did you see this?

I am pretty sure you run into this issue. The workaround is definitive NOT to run the script 2x 3x … times.

The fix should come in the coming days if you cannot wait you need to clone the git repository.

Keep in mind:
“Don’t ever run any code that you don’t trust. And the only way to truly trust code is to understand what it does.” @Sven

If you need some reasonably secure system go with the default Qubes settings. Over time you will learn how to further tweak your system.

1 Like

Ahhhh

You need to create the directories

I need to create 20 of them … You run one … And create what it say … Another time …other directory

1 Like

The author knows about he forgot to create them in the git repo, the last commit was to create them but not all were created.

1 Like

Yes that is a solution, but when you tried to create some qubes … It fails with disk error that can not be found and it was because a time out in the script, also some qrexec fails because of that at least in my machine when I tested it some time ago

I use it in a old machine that I have only for testing new additions before add it to my working machine, when I have enought free time to understand and read all the shell scripts that it use and see why it fails in some parts, and know how it work and what it really does, then I will trust it for myself or not in the working machine, it the same than always.

1 Like

Fix is out

Added print qube creation
Migrated to mirage-firewall by default
Installer fixes

1 Like

Thank you. I’m already getting started on the tests.
Perhaps we should create a separate thread for notes about Liteqube? Or we could use the “Automated Debian Scripts” branch for that, don’t you think?

Yes, agree.
Let’s start a Liteqube thread.