Libreoffice starts with windows almost invisible

It starts with windows almost invisible zero in size which need to be resized with the mouse…

yes, had this too back in 4.0 times. Not sure if this still happens on 4.1.
Do you have 4.1 already in use?

Version 4.1RC2.

does this happen in Fedora or in a Debian VM ? Could swear it’s the Debian, which is causing this bug. It won’t happen on a Fedora VM. But maybe I’m wrong…

Fedora 34!

2 Likes

A post was split to a new topic: 100% cpu with every scroll in LibreOffice

Worked for me too. So your post should be the solution…

2 Likes

Didn’t work for me but didn’t look too deep into it.

Thanks, it worked. I had to close running libreoffice windows before editing.

1 Like

It’s possible to hunt down all of the confingurations or setup Xdefaults but, …
For a more generic alternative, there is a script that will adjust all window sizes within a workspace reference in another forum thread:
(Tips and Tricks - #12 by 1of7)
For example, this will cascade all windows if the command line option ‘cascade’ is selected.
If the script is placed in /usr/local/bin then creating a keybinding Alt-Esc using the command ‘/usr/local/bin/winfuncs.sh cascade’ will cascade (omit quotes) all windows in the workspace by hitting Alt-Esc.
Windows can be cascaded, tiled, etc.
Window placement and offsets are all accessible.
Works with xfce, KDE, fwm, gnome, …
Requires xorg, will not work in wayland.

Tried this and though the settings remain changed, the windows still open extraordinarily small.

Solution is here. https://github.com/QubesOS/qubes-issues/issues/3281#issuecomment-638962391

Make sure to have libreoffice closed when doing it or it overwrites your entries. Make those changes, save it, restart the qube and reopen. It will open libreoffice with those sizes.
Note: There is one entry for each libreoffice app. Therefore change each.

Sure you have changed both of the lines and libreoffice closed beforehand? That happened to me that time.

This worked or me too
but it requires some work :wink: