Libreoffice in qubes full vs non-full screen mode

I’m wondering if any Qubes users have found a method for opening a new document in Libreoffice in a non-fullscreen mode in a set amount of horiz x vert characters by default, after a Qubes restart. This has been somewhat frustrating for me.

My system: Desktop computer. Qubes 4.1 with Libreoffice programs in a debian11-hvm template and a “doublewide” monitor, so that I can view two documents side by side. Libreoffice Writer being opened in the Personal vm.

Behaviour: If I view a document, reducing the screen size to one half (side) of the double-wide monitor screen and save it, the document will open next time as intended in the same size (reduced to half screen).

But when opening a new document in Libreoffice Writer, the screen always defaults to fullscreen mode, filling the entire screen horizontally but showing only half of the height of the page. Also if I am opening the first new document of the day after my usual night time system shutdown, I will also get a one-time message box, which I need to clear, stating that the document will not fully open in the screen. I would like a way to preset the first opening of a new document to a specific size filling just half of my wide screen. I have thought there might be a way to make a Libreoffice Writer settings change in the debian11-hvm template and have it carry over to the Personal vm. But no joy there so far.

Possibly this should be asked on the libreoffice forum. But I figure, there must be more Qubes users like me with the same problem. Maybe it’s a template vs working vm thing. cheers

Have the opposite issue with docs/sheets opening as tiny stripes were you can barely position the mouse pointer over.

1 Like

You can use the command ‘libreoffice --writer’ it opens an empty document with the same window size as the previous window.

Thanks renehoj. I just tried “libreoffice --writer” from the Terminal in my Personal vm and I’m afraid it opened full screen. I needed to click on the unmaximize button still at the top right corner and then resize the window.

You can try resetting libreoffice by deleting ~/.config/libreoffice

I just tested my work qube, it had the same issue with always opening the window in fullscreen. Resetting the settings seems to have solved the issue, now it remembers the size of the previous window.

Hi renehoj; I’ve just deleted the .config/libreoffice contents and folder, restarted and opening libreoffice writer still yields a maximized writer window. There is now also an error msg, when I open libreoffice writer -

Error loading BASIC of document file:///home/user/.config/libreoffice/4/user/basic/Standard/script.xlb/: General Error General Input/output error

Getting back to this problem now. I tried the LibreOffice community forum for possible answers. But that seems to be a dead end, when using Qubes. My monitor is a 2560x1080 for double-wide docs and I would like to open LibreOffice (Writer for instance) in just one side of the monitor screen. I can successfully do this for other than LibreOffice (ie- Thunderbird, Firefox, etc) and the system realizes opening in half screen. I’m not sure if I should be concentrating on LibreOffice Writer in my debian hvm template or in the Personal vm, to attempt a fix. I’ve tried both with no luck so far. When I first open LibreOffice Writer in the Personal vm, I would like it to open unmaximized at a resolution of 1280x1080 (or close to).