Librem 13 v 3


Seems to sleep though it may be very very slow after waking up (which a full shutdown/restart will clear).

As with any qubes installation you’ll want over 8 GB ram (though with minimal templates 4GB did work.

Keyboard (but not touchpad) is “grabbed” by Sys USB for usb keyboards. I also plug in a regular mouse; it too must be explicitly handled if installing sys-usb.


brand: |
model: |
Librem 13 v3
bios: |
cpu: |
Intel(R) Core™ i7-6500U CPU @ 2.50GHz
cpu-short: |
chipset: |
Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers [8086:1904] (rev 08)
chipset-short: |
gpu: |
Intel Corporation Skylake GT2 [HD Graphics 520] [8086:1916] (rev 07) (prog-if 00 [VGA controller])
Intel Corporation Device [8086:9d24] (rev 21)
gpu-short: |
network: |
Qualcomm Atheros AR9462 Wireless Network Adapter (rev 01)
memory: |
scsi: |
Samsung SSD 860 Rev: 2B6Q
usb: |

  • works:
    qubes: |
    xen: |
    kernel: |
    remark: |
    credit: |
    link: |
1 Like

Your HCL report states that you have 32GB of RAM. How did you arrive at the above statement?

By default Qubes allocated 4GB for dom0, is that what you meant?

Do you mean that the internal keyboard of this laptop is a USB keyboard?

I have 32GB now, but when I first ported qubes, I only had 4GB. I was able to buy an 8GB stick at a local shop, but that was not enough either, so I got a 32 GB. (But yes your question is valid because the usual commands to check memory will only return what dom0 sees. And it’s possible my original memory was actually 8GB–I didn’t know the correct command to check before I removed it. (xl info). In either case, it wasn’t the 32GB I am running now.)

As for the keyboard, apparently it IS one of those “internal USB” things. I know it would not function without the setting (I can’t remember what it is) for a USB keyboard. Likewise my wireless (and obviously USB) mouse. The touchpad was unaffected by running sys-usb.

1 Like

An addendum.

Sleep appears to work…but when the machine resumes it runs very, very slowly. I have no idea, yet, why this is so.

I re-installed my original RAM, which I thought was only 4GiB. I used the proper command to check it and it was actually an 8GiB stick.

So here’s the timeline: 1) Installed Qubes on my laptop. It would run into problems opening VMs, but it did run. I ran “free” to check the memory and it looked like I only had 4 GiB on it. I had no idea that was wrong. 2) Went to a brick-and-mortar store to get more RAM; a 16GB wouldn’t boot (and they didn’t even have a 32 GiB) but an 8GiB would, so (thinking I was upgrading), bought that. I did notice it didn’t seem to help very much. 3) Discovered that free still showed 4GiB; thought I had bad or mislabeled RAM. Then I learned the correct command xl info which showed 8 GiB. But I was unhappy with the limitations I was seeing, so: 4) Went to another store farther away and tried out a 32 GiB stick; it worked. xl info showed 32 GiB and life was good (the system is slow especially after sleep but it does run and I don’t run into “not enough memory” messages. I ran the report at this time which is why it showed 32GiB not 4 (not that it ever would have, but I didn’t realize that).

Sven asking if I might have used the wrong command to check my RAM eventually got me to thinking.

I was about to assure him that I really had only 4GiB of RAM originally (not when I ran the report) but then I realized that I had never checked the very first memory stick’s capacity with xl info. I have now done so and it turns out it was really an 8GiB stick all along; I never actually ran QubesOS in 4GiB of RAM.

That said I probably did benefit from minimal templates to some degree; sys-usb, sys-net and sys-firewall, as well as vera-store all ran as well as a browser qube; I could also run two app qubes that did not use a browser simultaneously in 8GiB.

(Oh, and when I reinstalled the 32GiB stick the system wouldn’t boot, until I took it out and reseated it. So it seems to be very finicky about how the RAM is seated.
That 16 GiB at the Brick and Mortar store from step 2 probably was fine.)

1 Like

Thank you @SteveC for your HCL report, which is online now!