Lenovo X13 Gen1

Hello everyone,

I’m new to Qube OS and tried to install it on a brand new Lenovo X13 Gen 1 (Spec techs here : https://www.lenovo.com/ch/en/laptops/thinkpad/x-series/ThinkPad-X13-Intel-/p/22TPX13X3N1)

I succeeded but it di not worked as I would have hoped.
First of all, the setp required an USB mouse as the trackpad is not recognised and an usb wifi dongle (I used my phone as tethering device). The display was extra slow and not responding well (Extra lag on screen refresh).

After the installation, I updated linux kernel on DOM0 to kernel latest (v.5 something) and the display went fluid and the trackpad worked.

However, I failed to use my network adaptor cards despite my attemps to add the provided firmware. Does someone have experience with it ? Because for now, I gave up on the installation of a linux machine on this spledid hardware because I do not want to have to plug external dongles for connectivity everytime.

Additionnaly, I failed to get the fingerprint authentication mechanism. Did someone managed to get that running ?

FInally, before switching to Qube OS (If my connectivity issues can be solved), I was wondering if running a Win 10 VM/Qube is currently possible or planned ? My work requires this OS and I’d like to be able to combine everything in separated environments but it needs to be working correctly.

Thank you for this great product and your comments,


Hi @johndi89,

Did you also switch sys-net to the 5.x (kernel-latest) kernel? Qube manager, right clic on sys-net, Qube settings, Advanced tab, Kernel: combo box. Then restart sys-net.

Does lspci detect your network adapter card?

See also this issue, not related to your network hardware but with useful command for analyzing your wifi problem.