Lenovo Thinkpad X13 AMD Gen 1 (Renoir, Ryzen 7 Pro 4750U)

I’m trying to run Qubes 4.1.1 on a Renoir Thinkpad. First I installed fedora 36 to check general linux compatibility and everything worked fine.

My present issue with qubes is that the keyboard is gone after waking up from standby and I don’t know how to isolate the issue. Kernel in sys-usb and dom0 is 5.15.64-1.fc32.qubes.x86_64.
I failed to extract kernel logs from after waking up because I don’t get access to the machine. I have to do a hard reset to regain control.
How do I proceed from here? How to I gain access to relevant logs? Did anybody have similar issues on this platform?

Please take a look at this:

My time to debug the issue is limited, the issue has ~130comments and it’ll take me some time to dig through them. This is no complaint - I’m just trying to be transparent about my progress and publish it here to structure my process. It’d be great if this became helpful to other people at some point.

I’ll start by writing down a couple of questions that I’ll try to answer along the way:

  • Is my problem (keyboard does not wake up after resume) related to the linked issue (screen dos not wake up after resume)?
  • Which GPU driver is in use?
  • It’s been years since I built my last kernel, I never did it on qubes. Do I need to build my own? Do I need to build the amdgpu driver myself? Is it packaged for qubes already?
  • How do I get access to log data from the time my system is unresponsive?

I started by scanning /var/log/Xorg.0.log for errors (EE):

(EE) Failed to load module "amdgpu" (module does not exist, 0)

To me this means two things:

Is my problem ( keyboard does not wake up after resume) related to the linked issue ( screen dos not wake up after resume)?

My initial problem is probably not related to the issue posted by @augsch

Which GPU driver is in use?

I don’t care too much about which driver is in use right now (vesa?). I’m not using the correct driver for my graphics card and I need to install it. I installed the driver (sudo qubes-dom0-update xorg-x11-drv-amdgpu), rebooted and looked at the /var/lib/Xorg.0.log again.

Now, I’ve got the same problem. :expressionless:

Fortunately I’ve got ~130 replies that might help me fix it.

The workaround to disable hardware acceleration from the description of the issue kind of works.
I added

Section "Device"
	Identifier "card0"
	Driver "amdgpu"
	Option "AccelMethod" "none"

to /etc/X11/xorg.conf.d/50-video.conf.

I also added preempt=none to GRUB_CMDLINE_LINUX in /etc/default/grub as described in Where to add kernel parameter? and verified it’s in use by checking proc/cmdline contains the string.

The discussion is led by isodude (I envy your patience and persistence) trying out many different kernel versions, xen versions & kernel patches. Other people are weighing here and there. I for one failed to extract anything that would improve my situation.

The gist seems to be that amd does not include xen in the qa process resulting in a cubersome experience for qubes users: They experience lots of small errors the first time because few/no other people run xen on their desktops.

This leaves me sad because it seems I’m left with two options:
a) buy an intel machine again and use qubes
b) keep the machine and use linux
Considering time and money required to stay with qubes I’ll probably have to postpone my migration to qubes another few years.

If I’d value my security less than my iron with a keyboard, I’d would do exactly the same.

Still, it’s a real pity this machine is not supported well.
HCL contains a report of a working t14s on cezanne and reports of multiple working renoir machines, some even from lenovo.
Yet, it doesn’t seem to work an the x13. Is there anything in particular, that lenovo did that prevents qubes from working on the x13.

Have no idea about details, but if components fit, then wildly blind guess would be something with bios Updating or setting. Then with kernel opts…