Lenovo ThinkPad X1 Carbon Gen 11

The /dev/nvme0n1 is your Qubes OS disk but there is a problem with partition table.

GPT PMBR size mismatch

Did you clone the Qubes OS installed on another disk to this one?
Or you’ve done clean installation on this disk?

Clean installation on the disk. Just tried downloadning from torrent this time and installing It with Rufus on another flash drive, this lead to the same “size mismatch” error.

Try to run this command to double check and fix the partition table:

parted -l

There was no result when I did it with hd0.

When I did it with hd1 I Received the following options:

Possible files are grubx64.efi, grub.cfg, grub.cfg.rpmsave

I tried completing it with .cfg hit enter and qubes started woop woop :raised_hands:t3:

What change do I need to make to not have to go through this procedure every time?

You could see if it’s the BIOS failing to find the UEFI path that Qubes OS uses - open a terminal in dom0 and run:

sudo -i
cd /boot/efi/EFI
cp -r qubes/* BOOT
mv grubx64.efi bootx64.efi
mv grub.cfg bootx64.cfg

and try to reboot.

Note: you’ll have to repeat this, each time Qubes updates grub.cfg in dom0… :-/

If it works, would you be willing to try some alternative ways to get it working?


1 Like

Wild - it works ! Thanks a bunch, @ChrisA and @apparatus !

Yeah sure happy to experiment with other options if it can help the community

The test I would like you to do, is to open a terminal i dom0 and

sudo -i
cd /boot/efi/EFI/BOOT
mv bootx64.cfg bootx64_works.cfg
echo "configfile /EFI/qubes/grub.cfg" > bootx64.cfg

and reboot.

It will save the working bootx64.cfg and try to instruct GRUB to look in the normal place for the grub.cfg (where it’s updated by default).

If it fails to boot, and you get stuck with a grub> prompt, you can try to enter:
configfile /EFI/BOOT/bootx64_works and hit Tab.

In case the test fails, it can be reverted (permanently) with a dom0 terminal and:

sudo -i
cd /boot/efi/EFI/BOOT
mv bootx64_works.cfg bootx64.cfg


It booted successfully :pray:

Does this mean I do not have to go through this after each dom0 update? :slight_smile:


Could you try to open a terminal in dom0 and do:

sudo -i
cd /boot/efi/EFI/qubes
cp grub.cfg grub_working.cfg
sed -ie 's/Qubes, with Xen hypervisor/Qubes, with Xen hypervisor - testing/' grub.cfg

– this should change the title you see when the computer boots … so try an reboot and see if the title includes " - testing". If the title includes " - testing", then I think updates to kernel in dom0 should automatically be applied to your config …


I did not see ‘testing’ after doing this, when booting.

Strange – I’ll find my USB sticks and try to make (and break) a fresh installation in order to do a bit of testing myself.

Since it didn’t have the " - testing", I assume you’ll have to update grub manually, when Qubes OS updates the kernel. :-/

Check this issue:

Now the /boot/efi/EFI/qubes/grub.cfg contains:

search --no-floppy --fs-uuid --set=dev X-X-X-X-X
set prefix=($dev)/grub2

export $prefix
configfile $prefix/grub.cfg
1 Like

Oh! - my primary Qubes machine is still on R4.1 … I’ve only started testing R4.2 on an old laptop (dead battery, so not one I bring with me). :-/

@abbedda: Sorry for giving bad advice! :frowning:

1 Like

Dont worry mate, you and @apparatus helped me to a State where I Can now use the OS :pray:

Thank you

1 Like