Lenovo ThinkPad X1 Carbon Gen 11

Thank you! As soon you know if the 4G modem works or not, I will make my choice to buy or not.

Can you tell a bit about the specs on the computer and how Qubes runs? (smooth and fast, slow etc?)

Ok I’ll tell you when I get to test it.

Performance is great overall. I can run many qubes at once even with intensive things like YouTube and backups without any problems.

For battery life I got about 4.5 hours of active usage including web browsing and video watching without trying to optimize anything. It could probably improve.

Graphics are smooth in dom0 including window compositing effects. But of course they get lower framerate and more CPU intensive inside qubes because there is no GPU passthrough. That’s not the laptop it’s just Qubes OS design.

Couldn’t make the 4G modem work with Qubes OS. It works with Ubuntu but not with Qubes OS and I don’t know why. Attach the PCI device to any qube and it fails to boot.

Hi. Which WWAN module do you have? Fibocom L860-GL-16, right?
Have you try this/seen this page?

  1. Fibocom Wireless WAN L860-GL-16 FCC Unlock and SAR Config tool for Linux - ThinkPad - Lenovo Support US
  2. https://download.lenovo.com/pccbbs/mobiles/n3xwp02w.txt


So I got the gen 11 now too, I can boot from the qubes installer from the flash drive and go through the install, but once its done installing and I’m asked to reboot, nothing happens - I then get stranded in a Lenovo boot menu like no OS is installed.

Any advice? Did you have any similar issues?

Did you install Qubes OS on removable disk?
If yes then follow these:

If it’s internal disk then follow this:

Thank you! Its installeres on an interval disk, my next question is How to apply these changes, I found the menu but my prompts are not working

Then follow the second guide, this one:

Not sure what are you talking about. Can you describe in more details?

I follow the guide, write reboot and it ends up the same place. Here are some pics of what I see

The screen showing when I turn on the computer (before and after following the guide)

My input and answer when following the guide

My boot settings

Boot order is:
Windows boot manager

Intel Vt-d is turned on

Boot order lock is on

Boot mode is: Diagnostics

Did you make sure that /dev/nvme0n1 is your Qubes OS drive?
Did you check it? Using fdisk -l / blkid / tried to mount it / or something else.

No, im quite new to Linux, how can I do that?

As I see it I can not even boot into the Qubes OS environment from where I can open a terminal

Run these commands:

fdisk -l

In the rescue mode shell before running efibootmgr and check the output.
The output of fdisk for your Qubes OS drive with default partitioning should have 3 partitions and look like this:

1 Like

It looks like that

Any other suggestions, @apparatus ?
And just so you know it, I highly appreciate your help here - thanks SO much :raised_hands:t3:

I assume you have the installation stick around still … so could you try:

  • Connect the USB installation stick to the computer
  • Select the Installation stick as the boot medium
  • When you see the “Install Qubes OS R…”/“Test media and …”/“Troubleshooting - …” menu, hit c to get a grub> prompt
  • Type configfile (hd0,gpt1)/EFI/qubes/grub and hit the Tab key on your keyboard – did it complete the line to: grub.cfg?
    – if so, hit enter … if no, try with: configfile (hd1,gpt1)/EFI/qubes/grub and hit Tab

and report/share the result?


The /dev/nvme0n1 is your Qubes OS disk but there is a problem with partition table.

GPT PMBR size mismatch

Did you clone the Qubes OS installed on another disk to this one?
Or you’ve done clean installation on this disk?

Clean installation on the disk. Just tried downloadning from torrent this time and installing It with Rufus on another flash drive, this lead to the same “size mismatch” error.

Try to run this command to double check and fix the partition table:

parted -l

There was no result when I did it with hd0.

When I did it with hd1 I Received the following options:

Possible files are grubx64.efi, grub.cfg, grub.cfg.rpmsave

I tried completing it with .cfg hit enter and qubes started woop woop :raised_hands:t3:

What change do I need to make to not have to go through this procedure every time?