Lenovo ThinkPad P1 Gen 4

Thank you @cheerfultuck for this HCL report, which is now online.

Where are you finding the Lenovo Thinkpad P1 (Gen4) without nVidia graphics?

It varies from country to country and time to time. I was lucky enough to get a pre-built model with the specs I wanted, but if not, you can choose the customize option (on either the X1E4 or the P1G4; they are for all intents and purposes the same). In the customise option, if you choose the i7-11850H processor, it should give you an option to select the iGPU only:

“The i7-11850H processor is available with Intel Integrated UHD, NVIDIA® GeForce® RTX™ 3050 Ti and 3070 graphics cards.”

P1 (Gen 4)

X1 Extreme (Gen 4)

The Lenovo PSREF is a useful resource when trying get more verbose information about the hardware models and configurations available.


See my post on the P15 Gen 2. It works fine with the nvidia.

Hey, i had similar experience with P15 Gen 2 as you did with the WLAN and bluetooth adapter. Both very minor issues.

Everything else appears to work out the box. Not sure what issues you are having with USB. I did a quick test using fedora gnome disk utility benchmark feature on a USB3.0 drive and I was getting I think 100read and i think about 20 write. Not sure if that is good or not.

I am having this issue right now testing a P15 Gen 2 that has both iGPU and dGPU. The same external display works on a Thinkpad P51 (iGPU+dGPU) running Q4.0. It also works via HDMI to a Librem 14 running Q4.1rc3. On the P15Gen2 the display does not work (hdmi or usb-c).

You mention here messing around in dom0 to fix that and I was wondering what that fix is?


This issue is occurring because some vendors/models have the external display ports hardwired to the dGPU (if present) and there may not be BIOS options available to change this behavior. My previous workstation was a Dell Precision 7520 and although it had a nVidia M2200, the display outputs weren’t hard-wired to it so I could run external monitors off the iGPU which meant it worked well with QubesOS. Lenovo with their most recent gen of Thinkpads have made the decision to hard-wire external displays to the dGPU from what I’ve been able to determine.

From what I understand, “messing around in Dom0” would involve working through getting Dom0 to support graphics output via the nVidia GPU. This can be achieved via “nouveau”, a project orientated around open-source drivers for nVidia cards, but to be honest from what I’ve seen, it’s a bit of painful experience. I’ve always done what I can to avoid having to deal with it on a QubesOS machine; hence why I was only interested in the iGPU only models.

Another option could be by using DisplayLink (not DisplayPort) based adapters or hubs/docks. This involves installing DisplayLink software in Dom0 and thus you may be able to drive external monitors. DisplayLink may be OK for productivity type workloads.

Neither are ideal as you’re putting software in Dom0; which ideally you really want to keep as clean as possible. Sorry I couldn’t be of more help, I’ve always tried to shy away from dGPUs for my QubesOS workstation.

Lenovo Thinkpad Mobile Workstation P1 G4

This is the model with NVIDIA® Quadro® T1200 GPU. Qubes OS used 4.1.1 with Fedora 36 templates.


– Forced to turn off bluetooth in the Bios, as it flickers in the SYS-USB vm and drives you nuts.
– WIFI doesn’t work. ( There was a workaround somewhere to delete some files in the sys-net template and it started working on Fedora 35, when upgraded to fedora 36 the work-around did not work anymore )
– The same problem exists with any other USB-WIFI dongle I tested. Nothing works.
– Using external display is a major pain. Was forced to turn on NVIDIA card permanently through BIOS, and even then it works only with one of the USB-C ports and as soon as you touch display arrangement in the settings everything goes bananas. There is no way to turn off the NVIDIA card in the BIOS unfortunately, only hybrid and NVIDIA only settings.
– There is a Window management issue when I switched to fedora 35 and 36, some apps window crashes but they are still running in the tasks. The same programs work in Fedora 34 and Debian 11 templates.

brand: |
model: |
bios: |
  N40ET35W (1.17 )
cpu: |
  11th Gen Intel(R) Core(TM) i7-11800H @ 2.30GHz
cpu-short: |
chipset: |
  Intel Corporation 11th Gen Core Processor Host Bridge/DRAM Registers [8086:9a36] (rev 05)
chipset-short: |
gpu: |
  NVIDIA Corporation Device [10de:1fbc] (rev a1) (prog-if 00 [VGA controller])
gpu-short: |
network: |
  Intel Corporation Wi-Fi 6 AX210/AX211/AX411 160MHz (rev 1a)
memory: |
scsi: |

usb: |

- works:
  qubes: |
  xen: |
  kernel: |
  remark: |
  credit: |
  link: |



Sorry, no attachment file as “new users can’t attach files” apparently.

These are really major problems and are interfering with daily work. I think we really need to think about embedding NVIDIA binaries or some open-source binaries at least in DOM0 from the top.

Qubes is a very resource hungry OS if you want to use it as a daily driver. There are almost no top tear laptops sold with no discrete GPU and as soon as you have discrete GPUs all sorts of problems comes to light. This is really making major issues and will be hampering Qubes adaptation going forward. ( i.e. I tries to buy the non-NVIDIA, Intel only version but with these supply issues you can’t get one )

Hi @Hammer, thank you for your contribution!

This is not a problem, it’s even more convenient to read as you put it.

This is why this list has been created: Community-recommended computers

I’m not sure if it will solve the problem for many users. AFAIK Nvidia=pain on Linux, and there is no nothing we can do unless they change.

See also: Frequently asked questions (FAQ) | Qubes OS

I am very well aware of those hardware recommendations. They are all 3-4 years old computers and not available to be bought new. Also their performance mostly suck, they don’t have a modern SSD, etc. and if you have a large number of VMs open ( as you must for daily usage ) everything becomes a pain.

I coudn’t even have 5-6 spreadsheets open at the same time on my 4 years old Thinkpad. Boot took forever with a SATA SSD, etc.

If the solution is to buy a 4 years old computer ( or older in many cases in that list), this OS is unusable. And I have to say it’s a number of years I am using Qubes, so I am very familiar with VM optimization, resource allocation, etc.

I also considered buying a Librum with per-installed. But apparently they can’t deliver anything. Just search reddit.

r/purism is exceptionally hateful to Purism. I would not rely on it to reflect the public opinion. There are quite a few trolls trying to harm Purism as much as possible. By the way, AFAIK similar thing happened to Pine64 until they created their own “official” subreddit.

Purism can’t deliver the phones indeed and have a huge problem with refunds, but the laptop delivery looks reliable from many posts.

Yes I agree with you on this one, but not all of us live in easy geographical locations. There are added variables for a lot of us, delivery issues, customs issues, etc. which adds to all other risks of buying from a small, relatively unproven vendor.

And, that’s the single laptop in that list which has a gen 10 CPU. Others are all Gen 3 or so. The former laptop I used Qubes on for a number of years, actually was way faster than all of the others in community recommended list, but still was dog slow for using Qubes as daily driver.

That’s the reason for switching to a more modern hardware to begin with. This OS needs to get adapted to the modern hardware realities. We can’t expect people to use a 10 years old hardware (as suggested in some of the community list items) to run such a sophisticated, multi-vm resource hungry operating system.

For a test or university paper maybe. For real world use-case, users need modern CPUs, modern IO and modern connectivity. Otherwise not only people won’t adapt it more, current users will leave.

You do realize that the upgraded CPU (3840QM) in the T430 is close to the speed of the 10510U (10th gen 4 core / 8 threads)?

The problem with the old ThinkPads is the memory limitations, it’s really not the CPU itself.

The problem is not CPUs. I had a 7th gen CPU on former laptop. Memory also can be increased which I did to 32GB on former laptop.

The Problem is IO. SATA SSD is DOG slow. You understand you open a new VM, a whole template is being replicated, right? Depending on your work you have various templates, different APP VMs, etc. That needs a fast IO otherwise you are just sitting there. Boot takes forever. Backup took 1 day on external storage. One can have 10-12 open VMs at a time for daily use.

For modern IO ( i.e. NVMe gen 4 SSDs or at least gen 3 ) you need new hardware.

Yes you can wait long times. But you shouldn’t. That is unacceptable for a “production” desktop environment in 2022.

Thank you @Hammer for this HCL report. Sorry to hear you are having these issues.

Your report is online now.

1 Like

Dear Sven;

Thank you. I really like qubes and it’s philosophy. I am a user since version 3. My former hardware HCL also could be seen here. I probably installed qubes on 7-8 different hardware, using it on daily basis. But it seems the more modern the hardware gets more problematic it becomes.

I would happily pay more to buy a qubes certified modern thinkpad workstation. As some of larger manufacturers started shipping Linux OS, maybe talking to Lenovo is not a bad idea, given that Thinkpads are the first choice for many people like us. :thinking:

I think it’s less the “modern” (unless you talk about ME) but the “new/fresh”. The laptops released in 2022 will mostly work just fine with Qubes OS … in 2025 :wink:

As @adw mentioned in another thread, sometimes it feels like one should by a laptop and then just store it in the closet for 2-3 years before attempting to install Qubes OS. I get that that’s not a message most like to hear and it’s probably also not the developer’s favorite comment. … but it does ring somewhat true.

1 Like

You can get that with desktops systems, I’m using a 12th gen intel with EVO 980 pro NVMe drives.

The problem is that you want it in a laptop, most bleeding edge systems don’t have great Linux support, which means even worse Qubes support.

I’ve moved your post into this thread so all the ‘Gen 4’ reports are in one place and updated the respective link in the HCL.