Lenovo Thinkpad L14 gen3 Intel


  • Graphics were really slow with 5.x Kernel - With Kernel Latest and 6.1.x its like a charm.
  • Also intel wifi wasnt recognized with 4.1.2, only after updates (maybe iwifi firmware or kernel 6.x - not sure but now it works)
  • with 4.1.2 out of the box the machine crashes when returning form sleep.
  • SD Card reader isnt properly recognized (didnt get a chance to find it yet
  • BIOS shall adjusted to only S3 Linux suspend, else the machine doesnt turn back on
  • make sure to deactivate secure boot, else your qubes USB stick wont boot.


Qubes-HCL-LENOVO-21C1CTO1WW-20230520-231631.yml (782 Bytes)

1 Like

Thanks for HCL.
Does it mean that after setting S3 in BIOS/UEFI suspend works for you with no issues in Qubes OS?

well only if i use kernel latest so i wasnt going into further detail else i might go over to github and raise an issue about:

  • the trackpad doesnt work sometimes when returning from sleep (trackpoint does)

Apart from that just regular kernel-latest issues i have on another machine as well (which i didnt check if they have an issue raised so far, sorry, lazy)

It may be connected with BIOS updates too, but probably kernel regression.
I myself have a new Thinkpad T16. I tried Kubuntu and suspend is working, but touchpad is not usable after resume (huge lags, moving cursor just a bit instead of normal functioning).
In Qubes OS after BIOS, dom0 and kernel updates suspend is not working at all. At the resume the laptop just reboots. It’s unfortunate that Xen/Qubes OS is that bad with suspend, because Kubuntu, even old one, suspends and resumes at least on the same hardware.

i outsmarted myself and found it deactivated in the bios settings, now it works…