Lenovo Thinkpad E14 Gen 2 Intel


With Qubes 4.1.1 and kernel-latest everything i tested seems to work. I can’t test HDMI audio, but after doing all updates, 3 HDMI audio devices show up. Sys-net has to be restarted after wake up from suspend to get wifi working again, trackpoint stops working after waking up.

Things i tried:

  • WiFi/Ethernet works
  • Touchpad, Trackpoint, Keyboard works
  • Keyboard shortcuts for mute, volume buttons, mic mute and brightness work
  • Bluetooth device shows up under USB devices
  • Speakers and headphone jack work, but sound really quiet/bad compared to windows (seems to be a problem in all linux distros i tried, might be just a configuration issue with alsa)
  • Headphone jack works (at least for output, couldn’t try input)
  • Internal mic and webcam work fine
  • Lenovo Thunderbolt 3 Dock Gen 1 works fine with cloned sys-usb for the usb controller in the dock and 4k screen via display port
  • Fans get angry as soon as i have more than a couple qubes running, even with tlp. I really miss power-profiles-daemon from the newer fedora versions for better power management. In windows and linux the fans stay off mostly
  • Battery lasts about 2-3 hours max compared to 7+ hours in Windows 11 with power saver and 5-6 hours in linux with power-profiles-daemon
  • Suspend works with the “Linux S3” setting in the uefi but breaks wifi and the track point. In earlier kernel and uefi versions it woke up but crashed completely soon after. Seems to be better now. I can’t tell what fixed it because i don’t suspend at all because of the wifi and trackpoint
  • Youtube in firefox is okay, as long as you disable the hardware acceleration
  • Video playback of high bitrate 1080p files works fine but the fans run on full speed. No fun watching movies with the very silent speakers and the fan noise.

Things i didn’t try:

  • Mic input via headphone jack
  • HDMI audio output

Other points:

  • With sys-audio sound works, but the keyboard shortcuts and the indicator lights stop working. Keyboard shortcuts can be fixed with xfce keyboard shortcuts in dom0 but i couldn’t get the lights to work again
  • The low volume/bad audio quality is really annoying because the speakers are really loud and sound great under windows. I played with the alsa config, tried setting model=auto via modprobe, tried selecting another output with hdajackretask from alsa-tools but had no success. It sounded even worse with most of the things i tried
  • altogether the performance with qubes compared to other os is okay and what to expect with the 11th gen mobile


brand: |
model: |
bios: |
  R1EET54W(1.54 )
cpu: |
  11th Gen Intel(R) Core(TM) i7-1165G7 @ 2.80GHz
cpu-short: |
chipset: |
  Intel Corporation 11th Gen Core Processor Host Bridge/DRAM Registers [8086:9a14] (rev 01)
chipset-short: |
gpu: |
  Intel Corporation TigerLake-LP GT2 [Iris Xe Graphics] [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
gpu-short: |
network: |
  Intel Corporation Wi-Fi 6 AX201 (rev 20)
  Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
memory: |
scsi: |

usb: |

- works:
  qubes: |
  xen: |
  kernel: |
  remark: |
  credit: |
  link: |


Qubes-HCL-LENOVO-20TA000DGE-20230122-190635.yml (900 Bytes)


Thank you, a great HCL!

  1. Please add the information about USB controllers to your HCL-post, it maybe very useful. The qvm-pci output would also be nice. I had ThinkPad L15 Gen 3 and ThinkPad E15 Gen 4 for a couple of days. It worth noticing that these devices have several USB controllers, which is a huge deal for Qubes OS. One can create sys-usb or other usbqube and pass only one usb controller and use another one for other things like printer/scanner qube or anything else in a standalone vm. Or have the controller with keyboard and mouse kept in dom0 to avoid input issues and use USB connectors in some qube independently.

  2. Your HCL reminds me recent mine of Macbook Pro :slight_smile:

  3. Any ideas on fixing fan issue that you mentioned?
    I have the same issue on Thinkpad T16 Gen 1.

  1. qvm-pci output is here:
[user@dom0 ~]$ qvm-pci 
BACKEND:DEVID  DESCRIPTION                                                                                                     USED BY
dom0:00_00.0   Host bridge: Intel Corporation 11th Gen Core Processor Host Bridge/DRAM Registers                               
dom0:00_02.0   VGA compatible controller: Intel Corporation TigerLake-LP GT2 [Iris Xe Graphics]                                
dom0:00_04.0   Signal processing controller: Intel Corporation TigerLake-LP Dynamic Tuning Processor Participant               
dom0:00_06.0   PCI bridge: Intel Corporation 11th Gen Core Processor PCIe Controller                                           
dom0:00_07.0   PCI bridge: Intel Corporation Tiger Lake-LP Thunderbolt 4 PCI Express Root Port #0                              
dom0:00_0a.0   Signal processing controller: Intel Corporation Tigerlake Telemetry Aggregator Driver                           
dom0:00_0d.0   USB controller: Intel Corporation Tiger Lake-LP Thunderbolt 4 USB Controller                                    sys-usb (no-strict-reset=True)
dom0:00_0d.2   USB controller: Intel Corporation Tiger Lake-LP Thunderbolt 4 NHI #0                                            sys-usb (no-strict-reset=True)
dom0:00_14.0   USB controller: Intel Corporation Tiger Lake-LP USB 3.2 Gen 2x1 xHCI Host Controller                            sys-usb (no-strict-reset=True)
dom0:00_14.2   RAM memory: Intel Corporation Tiger Lake-LP Shared SRAM                                                         
dom0:00_14.3   Network controller: Intel Corporation Wi-Fi 6 AX201                                                             sys-net
dom0:00_15.0   Unknown: Intel Corporation Tiger Lake-LP Serial IO I2C Controller #0                                            
dom0:00_15.2   Unknown: Intel Corporation Tiger Lake-LP Serial IO I2C Controller #2                                            
dom0:00_16.0   Communication controller: Intel Corporation Tiger Lake-LP Management Engine Interface                           
dom0:00_1c.0   PCI bridge: Intel Corporation                                                                                   
dom0:00_1c.2   PCI bridge: Intel Corporation                                                                                   
dom0:00_1d.0   PCI bridge: Intel Corporation Tiger Lake-LP PCI Express Root Port #9                                            
dom0:00_1f.0   ISA bridge: Intel Corporation Tiger Lake-LP LPC Controller                                                      
dom0:00_1f.3   Multimedia audio controller: Intel Corporation Tiger Lake-LP Smart Sound Technology Audio Controller            
dom0:00_1f.4   SMBus: Intel Corporation Tiger Lake-LP SMBus Controller                                                         
dom0:00_1f.5   Unknown: Intel Corporation Tiger Lake-LP SPI Controller                                                         
dom0:02_00.0   Non-Volatile memory controller: Sandisk Corp WD Blue SN550 NVMe SSD                                             
dom0:04_00.0   Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller  sys-net
dom0:07_00.0   Non-Volatile memory controller: Samsung Electronics Co Ltd

Regarding the USB controllers, what information do you need?

There seem to be 3 controllers. The device itself has just 1 Thunderbolt 4/USB Type C and 2 USB Type A (1 2.0, 1 3.2 Gen 1) ports. Both of the type A ports seem to be connected to the same controller. To use one controller exclusively for keyboard/mouse or printer/scanner, you’d have to use a dongle for the Thunderbolt port with charging passthrough if you want to use other external usb devices.

The Apple “USB-C Digital AV Multiport Adapter” and the Anker PowerExpand+ 11-in-1 both seem to be working for this, but the included 65w power supply is to weak to supply the thinkpad with the adapter under full load (battery keeps draining and recharging). I created the second sys-usb with the USB controller from my thunderbolt dock to automatically attach USB keyboard/mouse when the thinkpad is docked. Printer/scanner are in the network, so i can’t try more here.

  1. I saw your MacBook HCL entry and was very impressed with how structured your post was :innocent:

  2. The fan issue just seems to be normal for these devices. If you set the power setting under windows or linux with power-profiles-daemon to balanced or the highest setting, the fan is always loud under low - medium load. Performance with the power saving setting is more than enough for me, so i was hoping to get these newer power settings to work.
    I tried to compile power-profiles-daemon from source for fedora 32/dom0 to see if it works under xen, but it didn’t compile because of the old glibc version (needs 2.33 or 2.34+ iirc, fedora 32 ships with 2.31). I am no developer and have no idea what i am doing most of the time, so maybe someone else can make it work.

  1. That what I was excepting - 3 USB Controllers, it’s a big deal for some users and a lot of possibilities. Please, mention it in HCL (first post). It is important because one can not simply buy additional PCIe USB Controller for laptop the way it is possible for desktop PC. Librem 14 has only 1 controller, as I’ve heard.

  2. Nice to hear, thank you!

  3. I see. If or when you are able to make the fan noise go away - please update this post, I will be subscribed. I’m planning to use similar Thinkpad for Qubes OS myself and also tested it, finding cool the ability to play 1080pX2 videos of youtube, but disturbing the noise. Hopefully it is fixable.

I have a Thinkpad L14 Gen 3 AMD, which is very quiet. A review mentions it has 2 copper heatpipes compared to the Intel model and T series. Maybe the E series has just one as well.
You could check if a bios update has any effect. The changelog for mine mentioned an updated thermal table, I guess that means at which temperatures the fans are spinning at a certain speed. The sensors plugin in Dom0 xfce show about 2600 RPM maximum under load for me, but then it is still quite silent. I don’t think there are any bios settings for the fans though.

1 Like

Thank you @earthworm for your HCL report, which is online now!

Sorry for the delay!

1 Like